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Abstract

Despite some detractor’s opinions, Microsoft Project (MSP) CPM scheduling software is here to
stay as many contracts are now mandating its use. Most people using MSP on construction
projects find that MSP is fine for planning the work but very difficult to use when maintaining the
status and forecasting accurate project completion. MSP is also difficult to use when performing
delay analyses. The good news is that you can ‘make’ MSP properly reflect the consequences of an
update displaying proper Retained Logic. This paper will explain how to best use MSP in place of P6

or other more status-oriented scheduling software.



1. Introduction

Over the last two decades Primavera products became the predominant scheduling software of the
construction industry worldwide. Sadly, nothing lasts forever and many contracts have recently
started to specify MS Project (hereinafter referred to as, “MSP”) as the required scheduling

software.[1]

MSP has its advantages; it costs less than many of its competitors and it is ‘user-friendly’. It is easy
to start scheduling activities immediately. MSP easily produces decent default graphics and
reports. Another reason for MSP’s popularity is that a majority of US Federal Government PCs
come equipped with MSP. It is difficult to justify requesting the authority to purchase another

scheduling software when you already have one installed on your computer ‘for free’.

Most construction contracts for construction projects require periodic schedule updates. A
schedule update is an assessment of the project status and prediction of how and when the project
will be completed. Proper updating of the work schedule is an integral part of project management
and a critical communication tool between the parties. The schedule update should reflect the
current plan to reach project completion and an accurate record of the past performance. The
major steps in updating a schedule involve:

1. Setting a baseline

2. Updating the schedule

3. Comparing schedule updates

These steps are common to every software package and considered a regular course of business for
construction schedulers. MSP has many unique features specifically designed to make using the
software simple. However when it comes to updating a schedule using MSP, construction
schedulers often find MSP extremely confusing. This is mainly due to the MSP’s ‘ease of use
features’ getting in the way of reflecting the consequences of the current status. It gets even more
complicated if you ever have to do a forensic delay analysis on a MSP schedule. Cheer up, as all is
not lost. A clear understanding of how MSP calculates a schedule will make it possible to properly

use MS Project in place of a Primavera product, if needed.



This paper documents the complete process of tracking a schedule in MSP as well as the details of

how to ‘make’ MSP properly handle a typical status update involving out-of-sequence status.

2. MS Project Differences

There are a few operational differences between MSP and the Primavera products. Because MSP is
a Microsoft product, all work is performed in computer memory and you only save any changes
made if you tell the program to perform this operation. With products such as P6, all changes are
registered as soon as you press the Enter key. Because of the computer memory-centric scheme,
even in a multi-tasking environment of MSP Server, only one person can view the schedule at a

time.

MSP calls float values with the term, “Slack” and lists O as the value of slack for completed
activities. Finally, MSP only allows for one relationship between any two activities. This prevents

using the Start-to-Start and Finish-to-Finish relationship pairs found in P6 schedules.

MSP has unique concepts like Deadlines, and Recurring Tasks. In some cases, familiar scheduling
terms work different in MSP. For example “Multiple Critical Paths” in MSP means basically make
open ends critical. In some areas MSP lacks CPM functionality; for example the designation of a
longest path does not exist in MSP. For detailed explanation of MSP features and functionality, a
book such as Planning and Scheduling Using Microsoft Office Project 2007 [3] by Paul E. Harris can

be consulted.

The differences in the internal computational factors are even more significant. It is crucial to
understand how MSP calculates the schedule before delving into the mechanics of statusing a
schedule. Since most construction schedulers are familiar with Primavera, it is easier to compare

MSP to Primavera to point out the major differences.

Primavera considers every activity in the schedule when computing a CPM, even those that are
statused as complete [2]. Unless overridden by a constraint, all activities without a predecessor are
scheduled (with consideration to their calendars) to begin on the current data date (early start) and

their remaining durations/relationships are used to compute their early finish. This rule even



applies to completed activities with a remaining duration of zero. After all CPM calculations are
complete, Primavera then goes back to the completed and in-progress activities and overrides the

calculated dates with the actual dates.

This process allows Primavera to consider the delaying effects of uncompleted work due to out-of-
sequence progress under the Retained Logic calculation rule. Consequently, the Primavera Data

Date is the starting point and a fundamental piece of information for CPM calculation.

In contrast to P6, the default method of calculation for MSP does not require the scheduler to set a
Status Date (Primavera names it Data Date). This is simply, because MSP does not use the Status
Date to calculate the dates in the schedule. Instead MSP starts with the Project Start Date and
calculates the schedule using CPM rules even for the activities with actual dates. If an activity has
actual dates, the calculated CPM dates are ignored and the actual dates are used for calculating the
next activities’ start or finish dates. This is similar (but still different) to the P6 CPM calculation

mode, “Actual Dates.”

As shown in Figure 1 below, this process creates a potential for inherently flawed schedules with
remaining durations in the past or actual dates in the future. Both P6 and MSP suffer from allowing

actual dates in the future. P6 and MSP differ from how they handle incomplete work in the past.

Common sense and CPM rules require that activities with remaining duration scheduled in the past

must be ‘moved’ into the future. It defies logic to say “We will complete this work last month”.

o Task Mame Curation Eatly Start | Early Finish | Actual Start | Actual Finish | Total Slack [P [Aug 8,10 Aug1s,'10 Aug 22,10
S|M|T |W|T |F |S S|M|T |W|T |F 5 S|M|T |W|T |
1 ! Task 1 s days Maon B/940) Fri 84310 M, hd 7 days
2 | Task 2 T days Mon 3810 Tue 8M7M0 Man S840 Tue 81710 0 days -
3 Task 3 S days Wied 81810 Tue 872440 R M 0 days !

Project Information for, ‘MSP CPM Calc.mpp’

Stark date: Man &/2/10 »|  Current dake: | Thu8(5/10 h
Finish date: Tue 82410 Status date: | Fri §i20/10 “
Schedule from: Project Start Date hd Calendar: Skandard b4
l Help l [ Statistics... l I Ok l [ Cancel

Figure 1 — Remaining Duration in the Past



Even though MSP is not designed to calculate the schedule from the Status Date, there are option
settings available in MSP to simulate CPM calculations based upon a Data Date. This somewhat
complicated process involves the use of built-in routines that add activity constraints and adjusts

some internal dates.

For MSP to simulate the effects of a Data Date, all unstarted tasks are given a Start-no-earlier-than
constraint date equal to the status date and all started but incomplete tasks have their Resume
Date set to the Status Date. This method delays the incomplete and unstarted tasks to the Status
Date. During this process, tasks with constraints lose their previously set constraints and tasks that
never had a constraint before now get a constraint. This is not desirable, but unfortunately it is the
only way that MSP observes the Data Date. Figure 2 below displays, the constraints assigned by

MSP to observe the Data Date.

i ] Tazk Mame Curation Early Start | Early Finish Constraint Type Constraint Aug §,10 Aug 15,10 Aug 2210 &1
Date F |S = M|T |'IN|T |F |S S|M|T |W|T |F = S|M|T |W|T |F |S =
1 [E Tazk 1 S davs hdon S23M0 0 Frigf27in Start Mo Earlier Than Fri 820010 _-I
2 Taszk 2 T days hon 28M0 Tue 8M7H0 0 As Soon As Possible rla, |-_
3 |[E Tazk 3 3 days hon S23M0 0 Frig27in Start Mo Earlier Than Fri 820010 h
Update Project E]
() Update work as complete through: Fri &f20/10
(3) Reschedule uncompleted work to start after:  |Fri&20/10 “
For: (%) Entire project () Selected tasks
o (o

Figure 2 — MSP observes Data Date using constraints

3. Tracking a schedule with MS Project

The complete process of tracking a schedule involves setting a baseline, updating schedule status
and comparing the updates to the baseline or previous updates. For brevity, this paper assumes
that the reader is familiar with MSP user interface as well as its basic functionality and deals mainly
with general steps that an experienced construction scheduler would understand or expect.
Therefore starting with the schedule set up, we will cover setting a baseline, updating the schedule

and comparing the update to the baseline without detailed step by step instructions.




3.1. Schedule Set-up

Before explaining the details of schedule update process, it is crucial that the correct options are
selected and relevant points in time are displayed. MSP was designed to not rely on the Data Date.
There is Status Date which deceptively sounds like the Data Date in Primavera, but it is not the

same. Instead MSP relies on the Project Start date for calculation.

There is also a MSP Current Date which is the date of the computer when the file is open. If there
is no Status Date set then the Current Date is used for calculating earned value. Neither Current
Date nor the Status Date is used for calculating schedule dates and neither has any scheduling
significance. Neither of these dates is shown on the Gantt chart by default unless the user adds
them to the view. To reduce confusion, it is recommended that the Status Date line be displayed in
the Gantt views and Current date should not be displayed. Figure 3 shows the recommended

selection setting.

Gridlines 3

Line ta change: Tormal

Bottom Tier Column Al Ivpe [———— ~| Color: [ Red  |v

_urrent Date
Sheet Rows !
Sheet Columns Bliendl

Title Yertical a
Title Horizontal

Page Breaks

Project Start .
Project Finish [ whice
Status Date

Top Tier Colurmn b [ ok l[ Carncel ]

Figure 3 - Recommended Status Date Selection Setting
It is difficult and confusing to implement changes to the CPM calculation modes after an activity is
added. To prevent errors and confusion, we strongly recommend that you configure your MSP

schedule before adding the first activity. The recommended set-up steps are as follows,

1. Under the Tools / Options / Schedule Tab. Figure 4 shows this tab.



oprons T |

Calculation | Spelling | Collaborate | Save I Interface I

Yigw General Edit Calendar Scheduls

schedule options For Microsoft Project

W show scheduling messages

Show assignment units as a: |Percentage j

scheduling options For ‘Projeck1’

Mew kasks: |Start On Prajeck Start Date j
Duration is entered in: |Da':-"5 j
Wark is entered in: |HDLIrS j
Default task type: |Fixed Inits j

[w Rew kasks are effort driven

v autolink inserted or moved tasks

[v Split in-progress tasks

W Tasks will always honor their constraint dates
W show that tasks have estimated durations

v Mew kasks have estimated durations Set as Defaulk |

Help |

Cancel |

Figure 4 — Schedule Options Tab

Split in-progress tasks: [Checked] This option allows rescheduling of remaining duration and work

when an in-progress task is running longer than originally planned.

Tasks will always honor their constraint dates: [Unchecked] This option tells MSP to schedule tasks
according to their constraint dates, regardless of logic. Clear the check box to specify that task
constraint dates with negative slack (float) move according to their relationships with other tasks

rather than be solely scheduled according to their constraint dates.

2. Under the Tools / Options / Calculation Tab. Figure 5 shows this tab.



options |

Wigw | General | Edit | Calendar | Schedule

Calculation | Spelling Collabor ate Save Interface

Calculation options Far Microsaft Project

Calculation mode: e Ay tamatic " Manual Calculate Mows |

Calculate: ¥ )l open projects ) Active project

Zalculation options for 'Project1’
|w Updating task status updates resource skatus
[ Move end of completed parts after skatus date back ko stabus date
I |and mave starbaf remaiing parksiback bo status date

[~ iMove stark of remaining parts before status date Forward bo status date:

I [and move end af completed parts farward e statisdate

Earned Yalue... |

[ Edits o total task % complete will be spread to the skatus date
v Inserted projects are calculated like summary tasks
[v Actual costs are always calculated by Microsoft Project

[™ |Edits b batal | actial cast wil e ismre aa ko bhe statisdate

Default fixed costs accrual: Prorated j
[ Zaloulate mulkiple critical paths

Tasks are critical if slack is less than or equal to |U 3: days Sek as Default |
Help | (04 I Cancel |

Figure 5 — Calculation Options Tab

Updating task status updates resource status: [Checked] This option insures that task resource

status does not override update status.

Move the end of completed parts back to status date: [Unchecked] This option prevents actual
dates later than the Status Date (in the future.) It also changes Actual Dates without user input.
This is dangerous to do. ‘Bad’ Actual dates should be flagged, but not automatically changed. P6

allows actual dates in the future but does note these as warnings in the Schedule Log produced.

and move start of remaining parts before the status date forward to status date: [Unchecked]
This option ‘recovers’ dangling work left over after moving completed parts back to the status date.

This step is unnecessary, as the remaining work will be scheduled after the Status Date.

Move the start of remaining parts before the status date forward to the status date: [Checked]

This option prevents uncompleted work from being scheduled before the Status Date (in the past.)



and move end of completed parts forward to status date: [Unchecked] This option will move

complete parts of split tasks to the status date and will assign new actual dates.

3. Because we are going to be splitting tasks, any tasks created must not be assigned Task Duration

Type of, “Fixed Duration.”

These options may NOT be turned on and off to recalculate all tasks. The options only work on new
tasks when they are added to a schedule or when a task is updated by changing the % Complete.

This is why we address these settings before you begin adding activities to your MSP schedule.

3.2. Setting a Baseline
Establishing a baseline is the first step in monitoring your schedule. The term, “Baseline” can be
confusing here as MSP (and P6) uses this word to mean something slightly different than from its

universal use in the construction industry.

The construction industry labels a schedule as a Baseline Schedule if it is the first approved,
complete schedule on the project. This type of Baseline typically does not have any status
recorded against it. MSP and P6 calls a baseline schedule any copy of the schedule that is stored
‘internally’ in another schedule. This type of baseline is used for comparison purposes. In this
paper, we will call the initial construction schedule a Baseline Schedule (using capitol letters) and

the MSP schedule copy, a baseline schedule (with lower case letters.)

When a baseline schedule is made, MSP copies Early Start and Early Finish dates to the baseline
Start and Finish Date fields. Original Duration gets copied to baseline Duration. Each Task’s Costs
and Work is copied to baseline Costs and Work fields. Nothing else is saved in a baseline schedule.

See Figure 6, Set Baseline Screen.



Set Baseline g‘
@zt

2
Baseline w

() Set inkerim plan

For:
@ Entire project
(") Selected tasks

Foll up baselines:

o (e

Figure 6 — Set Baseline Screen

MSP treats the baseline as a snapshot of your schedule at the time that you created the baseline.
MSP does not store logic, float or constraints for the baseline and as a result, can not recalculate
any of the stored information. P6 users familiar with baselines will assume that they can convert
(or ‘unattach’) a baseline schedule back into a fully functional schedule. This is not the case with
MSP. Due to the fact that MSP baseline schedules do not store complete activity and logic

information, creating a MSP baseline is a ‘one-way’ process.

Baseline information can also be edited manually. Since baseline fields are editable by Users and
will not be recalculated by MSP, users should be cautious if they decide to change any of the
baseline information manually. The fact that it is all together too easy to accidently change this
information makes relying on the variance information more risky than with the typical

Target/Update procedure used with P3.

MSP allows for a maximum of 11 baselines. This is barely enough baseline storage for a 12-month
project without any Change Orders or Time Impact Analyses baselines. Users are strongly
encouraged to keep separate monthly backups in order to maintain and be able to prove past

status integrity.

There is also another MSP feature called, “Interim Plan” which has similar functionality as the

creation of baselines. This feature stores less information than a baseline. The Interim Plan
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function only stores the Early Start and Early Finish dates of tasks and not durations, costs, or work.
An interim plan can be compared against a baseline plan or current plan to monitor project

progress or slippage. MSP allows up to 10 Interim Plans.

MSP allows Summary Tasks to be added, deleted, and moved around. If a task is added, deleted, or
moved after the baseline is set, the baseline dates for Summary Tasks become invalid. MSP has a

feature called Roll Up baselines that would reset the baseline dates for Summary Tasks.

Another important issue with the baseline is that the Late Start and Late Finish dates are not
stored. All variance measurements are assessed from the early dates. Available float

considerations are not taken into account and are not part of the baseline history.

3.3. Updating the schedule
3.3.1. Updating Tasks
The first step in updating the MSP schedule is to understand how durations are calculated. Task

durations are comprised of four important pieces of information:

1. Duration (which is equal to Actual + Remaining Duration)
2. Actual Duration
3. Remaining Duration

4. % Complete (which is equal to Actual Duration / Duration)

The calculation of MSP Actual and Remaining durations is confusing to many schedulers, especially
for those who are used to Primavera products. First in Primavera, actual duration is calculated
based the activity’s actual date and the Data Date (or Actual Finish date if it exists) whereas in MSP,
the Status Date is not used in calculating actual durations.

Another reason for confusion is because MSP automatically links Duration, Actual Duration,
Remaining Duration and % Complete without an option to remove the link. Only any two of these

are independent, and the rest are calculated using the formulas listed above.

10



The scheduler needs to understand how these four pieces of information are calculated in MSP.

Table 1 below summarizes the interaction between these 4 duration-related task properties.

MS PROJECT WILL

Duration % Actual Remaining
Complete Duration Duration
o Duration Recalculate | Leave As-Is Recalculate
§ % Complete Leave As-Is Recalculate Recalculate
% Actual Duration Leave As-Is Recalculate Recalculate
= Remaining Duration Recalculate | Recalculate | Leave As-Is

Table 1 — MSP Calculation Rules

To illustrate how each of these fields is calculated, let’s review a simple activity with 10-day

duration as shown in Figure 7.

Task Mame Duration Actual Rem. Dur. Act. Start Act. Finish | % Comp. Lug 22,10 Lug 28,10 =
Duratian S[M[T[W[T[F[S|S[M[T [W[T[F|S|S
Task 1 10 davys Odays ~ 10days M, M, 0%
Figure 7 — Sample 10-Day Activity
Entering 20% complete will automatically assign an Actual Start date and calculate the Actual
Duration and Remaining Duration. Actual Start will be set equal to the Start date (for unstarted
tasks, MSP Start date field equals to early start date) of the Task as shown in Figure 8. Actual
duration will be 2 days, which is 20% of the Duration. Remaining Duration will be 8 days which is
Duration minus Actual Duration.
Task Mame Duration Actual Rem. Dur. Act. Start Act. Finish % Comp. Aug 22,0 Aug 29,10 =
Duration SM[TW[T[F[S|S[M[TW[T[F|5|5]
Tazk 1 10 days 2 days Goays  Mon 82340 (N 20%

Figure 8 — Result of Entering % Complete

If we further adjust remaining duration to 10 days, the Duration will become 12 days as shown in
Figure 9. This is 10 days remaining plus 2 Days actual. % Complete will be 17%, which is Actual

Duration divided by Duration.

11



Tazk Mame Duration Actual Rem. Dur. Act. Star Act. Finish | 9% Comp. Aug 22,10 Aug 29,10 Sep 5,10
Duration SM[T[W[T[F[S[S[M[T [WW[T[F[S|5[M[T [W[T |
Task 1 12days ~ Z2days 10cays  Mon 82310 M 17%

Figure 9 — Result of Adjusting Remaining Duration

MSP provides 4 different ways to enter actual data for each Task.

1) Using the Update Tasks Form as shown in Figure 10 is one way of entering actual data for each
task. This method is the least preferred method because the form has to be closed after updating
each task and opened again after selecting the next Task. This makes it very cumbersome to

update large numbers of tasks.
MSP allows you to use this function to update multiple tasks at once but the limitation is that MSP

assigns the same value to all. Therefore unless all Tasks have the same update information, this

function is not useful.

Figure 10 — Update Tasks Form
2) Another available update method is using the Task Information form as shown in Figure 11. This

is also a cumbersome way of updating because the form has to be closed after each update and

opened again after selecting the next Task.

12



Figure 11 — Task Information Form

3) Using the Task Details Form to update the schedule is a less cumbersome method compared the
previous 2 methods listed above. Task Details (as shown in Figure 12) can be opened by dragging
the divider line and selecting Task Details Form from View, More Views. If a Finish date is entered
without task being 100% complete, MSP will automatically add a Finish Constraint to the Task. For

this reason, this third option is also not recommended.

Figure 12 — Task Details Form
4) The easiest and most efficient method to enter activity actual date status is by using the Tracking

Table in the Gantt Chart or creating your own table as shown in Figure 13. It is recommended that

the following fields are shown on this custom table.

13



Figure 13 — Tracking Table

Once the detail tasks are updated, the summary tasks inherit status data from their detail tasks.
Actual start is assigned to the Summary task when a detail task has been given an actual start and
similarly Actual Finish is assigned when all detail tasks have been assigned actual dates. A
Summary Task’s % Complete is calculated by dividing the sum of all Detail Tasks Actual Durations by

the sum of all Detail tasks Durations.

MSP has a somewhat unusual feature that allows the scheduler to manually update Summary
Tasks. It is unlikely that this feature will be used by construction schedulers. The reason that we
say this is that a manual update of a Summary Task affects all the detail tasks below it. If a %
Complete is entered at the Summary level, MSP assigns values for Actual Duration, % Complete,
Actual Start and Actual Finish all the children tasks (Summary or Detail). Calculation of these
values differs based on the “Updating Task Status Updates Resource Status” setting. If “Updating
Task Status Updates Resource Status” is checked, the tasks are statused as if they were completed
per plan. If not checked, then all of the children tasks get the same % Complete value of the
Summary task. This is obviously a dangerous procedure to employ if the accuracy of individual

activity status is desired.
MSP has a feature called Update Progress which will automatically update the activity as if it

progressed as planned. This feature automatically sets the Actual Start, Actual Finish, % Complete

and Remaining Durations. There are 2 options available under this feature as shown in Figure 14.

14



Update Project g|

(%) 1pdate work as complete through'; Wed 7/14/10 w

(%) Set 0%, - 100%: complete
() 5et 0% or 100% complete anly

(") Reschedule uncompleted wark bo start afker; | Wed 7/14/10

For: (%) Eptire project () Selected tasks

o] Cow

Figure 14 — Update Progress Screen

Set 0% -100% Complete - Selecting this option will set Actual date to Early Start. Actual Duration

and % Complete will calculated based on the date entered in “Update Work As Complete Through”.

Set 0% or 100% Complete - Selecting this option will set Actual date to Early Start. Duration and %
Complete will be zero unless the “Update Work As Complete Through” date is later than Finish date

of the Task. Selecting this option will not reset the Status Date.

Either of these options can be applied to the selected Tasks or for all Tasks in the schedule.
Scheduler must be careful using this feature for various reasons. First, if Set 0% or 100% Complete
option is selected, the “Update Work As Complete Through” date and the Status Date might not
match. To make things worse, remaining durations will not move to any of these two dates,
resulting in remaining durations scheduled to be complete in the past. Similarly, if this feature is
applied only to ‘Selected Tasks’ then there is a possibility that there will be unstarted activities in
the past. Set 0% -100% Complete would produce reliable results only if everything is going per

plan. Therefore this feature is very limited in its use and not recommended.

3.3.2. Observing the Status Date

As explained above, MSP was not designed to calculate estimated schedule dates using the Status
Date. Forcing MSP to observe the Status Date is very complicated process that requires
understanding the calculation options in conjunction with using the “Reschedule Uncompleted

Work” on the Update Project form.

15



3.3.2.1. Reschedule Uncompleted Work to Start After
To properly update a schedule first we need to understand “Reschedule Uncompleted Work to

Start After” feature available on the Project Update form shown in Figure 15.

Update Project g|

(%) 1pdate work as complete through'; Wed 7/14/10 w
(%) Set 0%, - 100%: complete
() 5et 0% or 100% complete anly

(") Reschedule uncompleted wark bo start afker; | Wed 7/14/10

For: (%) Eptire project () Selected tasks

o] Cow

Figure 15 — Update Date Screen

For this feature to work properly, ‘Split in Progress Tasks’ must be selected under the Tools,

Options Schedule tab.

When this feature is used, MSP will go through each unstarted task and will assign a Start-No-
Earlier-than-Constraint equal to the Update Project Status date. Understand that MSP only allows
one early constraint per task. Because of this, if any of those unstarted tasks had a different
constraint, the existing constraint will be deleted in favor of adding the new CPM constraint. Tasks

that are in progress will have their Resume Date set to the Update Project date.

Another disadvantage to this process surfaces if one is required to destatus the project. To do so,
the scheduler has to review each activity and remove the constraints and adjust the task splits
manually. This makes it very difficult and time-consuming for analysts to perform schedule what-if

analyses.

In addition, MSP does not change the Status Date to the date specified in the Update Project
feature (Figure 15.) This often results in confusion as the date specified in Update Project screen
(Figure 16) is not displayed on the Gantt chart and might end up being a different date than the

one that is displayed. To avoid confusion and to display a correct Status Date on Gantt view, the

16



Scheduler should set the Status Date same as the date specified during Project Update function as

shown in Figure 15.

Project Information for ‘Project1.mppt g|
Start date: Wed 6/16/10 ~ Current date: |Wed 7/14/10 w
Einish dake: Maon 6/21/10 Status date: A W
Schedule fram: | Project Stark Date | Calendar: Standard w

’ Help ] [ Skakistics.. . ] QK l ’ Cancel

Figure 16 - Status Date Screen

Coordinating the date between the two screens only solves half of the problem because it moves
in-progress activities after the Status Date. As shown below in Figure 17, there still can be tasks in

the future with actual dates. Unlike with P6, there is no automatic notice in the CPM computations

report.
o Task Mame Duration Early Start | Early Finish Constraint Type Constraint Aug "0 Aug 15,0 Aug 22,'10
Date FIs|SIM[TW[TIF[S|S[M[TM[T[F[S[S[M]T W[T]F
B Tazk 1 Sdays  wWied BA8M0 Tus 824010 Start Mo Earlier Than | Tue GA7H0
Ve Tazk 2 T days hon 3840 Tue 8170 Az Soon Az Pozsible MA,
Task 3 Sdays  Wied 3MEM0 Tue 5/24M0 Az Soon As Possible I,

Figure 17 — Sample Schedule with Future Actual Dates

3.3.2.2. Status Date Calculation Options

MSP 2002 [4] and later versions have four CPM Options to force MSP to observe the Status Date. A

combination of options under the Calculation tab is shown in Figure 18.

Mowve end of completed parts after status date back to status date
And move skark af remaining parts back ko status date
Move skark of remaining parts before skatus date Forveard to status date

And move end of completed parts Forward ko skatus datke

Figure 18 —Status Date Options

These options move tasks around the Status Date, change assign actual dates to automatically

prevent incomplete work in the past, and complete work in the future. These options based on

17



their titles seem self-explanatory but have unexpected consequences for the unwary scheduler.

First of all for these options to function properly one must ensure that:

. Split in Progress Tasks option must be selected,

J Desired options must be selected before tasks are added,

J Updating Task Status updates resource status option must be checked,
. Task Duration type must be something other than Fixed Duration.

These functions are limited because:

J The options only work on new tasks.

. The options only work if tasks are updated using % Complete. If the task has 0% progress,
these options will not apply therefore unstarted tasks in the past will remain in the past unless the
scheduler runs project update form “Reschedule Uncompleted Work to Start After” feature

J Changing the options will not recalculate the CPM to display the effects of that change.

. If a Status date is not defined, MSP will use the Current Date without warning the user.

Tasks only reflect the CPM options if the tasks are updated by using % Complete. Changes to task
remaining duration will be reflected in the schedule, but not the effects of the changed options
rules. Therefore if tasks are updated by using anything other than % Complete, these functions are
not implemented, even if later set. This method of update is problematic as AACE Recommended
Practice 53R-06 [5], recommends updating an activity’s status by indicating the new remaining

duration estimate rather than indicating a new % Complete.

Preventing Incomplete Work in the Past

Logic tells us that you should not display planned work prior to the Data Date. This inconsistency in
status ‘hides’ work that must still be completed, ignores required resources, and disrupts the

correct calculation of planned dates for future work.

To illustrate how these options work, let’s look at a simple schedule shown below in Figure 19.
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Figure 19 — Task with incomplete Work in the Past
To prevent incomplete work in the past options shown in Figure 20 should be selected.

[ IMove end of completed parts after status date back bo status date

Mowve stark of remaining parts before status date Forward to status date

[ 1and move end of completed parts Forward to skatus date

Figure 20 — CPM Option to Move Incomplete Work Out of the Past

With these options selected, entering a % Complete value would assign an Actual start and move

remaining part of the task after the Status Date as shown in Figure 21.

Tazk hame it Start Aot Finish | % Comp. | Phys.%| &ct.Dur. | Rem.Dur. | |Au022,M0 [Aug29,10 [Seps 0[S
| | | Camp. | §J_§_|MiT|W!T|F|S|S|MiT|W!T|F|_SJ§|MIT|W!T|F|§J_§_
Tazk 1 Mo 872340 MA, 10% 0% 1 clay 9 days — i

Figure 21 — Result of Moving Incomplete Work Out of the Past
If the following option as shown in Figure 22 is checked in addition to the one described above.
[]Move end of completed parts after status date back to skatus date

Mawe skark af remaining parts before skakus date Forward to skatus date

and move end of completed parts forward Eo status date

Figure 22 - Additional CPM Option for Incomplete Work

The task split will be removed, actual start date will be changed, and the complete portion of the

task will be moved to the Status Date as shown in Figure 23.

Figure 23 — Result of Moving Complete Work to the Status Date
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This option will override any previously assigned actual dates; therefore it is recommended that it

remains unchecked. Assigned actual dates should never be automatically deleted.

Preventing Complete Work in the Future

To illustrate how these options work, let’s look at a simple schedule shown below in Figure 24. In

this example start of Task 1 is constrained to start no earlier than 20SEP10.

a Task Mame Duration % Constraint | Constraint Type Start Finish

Sep 12,0 Sep 19,10 Sep 26,10
Complete Date F =S |M[TW[T[F S |S|M[T[W[T[F[S|5|M[T[W[T[F|5
=] Tash 1 10 days 0% Mon @200 Must Start On| Mon 92204100 Fri10M A0 I

Figure 24 — Sample Schedule with Complete Work in the Future

To prevent complete work in the future options shown in Figure 25 should be selected.

Move end of completed parts after skatus dake back ko skatus date
[ ]and move start of remaining parts back ko skatus date

[ IMowve start of remaining parts before status date Forward to skatus date

Figure 25 — Future Options

If the task is updated by entering a % Complete, the actual duration portion of the task will be

moved to the Status Date and an actual date to match will automatically be assigned to the task.

[i] Task Mame Curation % Constraint | Constraint Type Start Finish

Sep 12,10 Sep 19,10 Sep 28, 10
Complete Date FIE|[E[M[T [T [F[S|S|M[T [W[T[F 5|5 |M[T[W][T[F |
Ed Task 1 10 days 10% Mon 9/20M0  Must Start On| Mon 9M3A10 Fri10MA0 | I

Figure 26 — Result of moving end of complete work back to status date

Selecting “And move start of remaining parts back to Status Date” sounds like the “Progress
Override” option in Primavera products. This is not correct as this option will also override existing
constraints. If the task has a constraint, selecting this option will erase it and bring the remaining
part of the task back to the status date.

The Results of our Settings

Now that we have our activities observing the Data Date, we need to compare this to what is
presented in P6 software. For demonstration purposes, we will take the typical 4-activity schedule

with out-of-sequence progress like that as shown in Figure 27 below.
20



Tazk Mame | Duration Start ‘ Firizh | 03 Jan 10 10 Jan 10 17 Jan 10 24 Jan 10 31 Jan 10 07 Feh 10
5|5 [slsM|Tw[T[F|s|sSM[T|w[T|F[s|S[M|[TWw[T[F[s|[s|M[TW[T|F[S|S[M][Tw
Act 1 5days Mon04-01-10  Fri 08-01-10
Act 2 Sdays Mon11-01-10  Fri15-01-10
Act 3 5days Mon18-01-10  Fri 22-01-10
Act 4 5days Mon25-01-10  Fri 29-01-10

Figure 27- Sample Out of Sequence Progress

When the out-of-sequence activity (in this case, Activity 2) has some remaining duration, then the

CPM Calculation Options forces the schedule to resemble Retained Logic as seen in Figure 28

below,
Task Mame | Duration Start ‘ Finizh ‘ 03 Jan 10 10 Jan 10 17 Jan 10 24 Jan 10 31 Jan'10 07 Feb Y10
SIEMITMWTIFIS|SIM[TWI[TIFIS[SM[TWI[TIFIS[E[M[TMW[TIF|S[SM[TMI[T[F|S[S[M[T [
Act 1 1 S ooays Wed 20-01-100 Tue 26-01-10
Act 2 13 days Mon 11-01-10 ) Wied 27-01-10
Act3 11 days | Mon 18-01-10 0 Mon 01-02-10
Act 4 Soays | Tue 02-02-10 0 Mon 08-02-10

Figure 28 — Retained Logic

When the same out-of-sequence activity has no remaining duration, then the CPM Calculation

Options forces the schedule to resemble Progress Override as seen in Figure 29 below.

Taszk Mame | Duration Start | Finizh | 03 Jan 10 A0 Jan 10 A7 Jan 10 24 Jan "0 31 Jan 10 07 Febh 10
| |SSWHMHWHSMHMHWESWHMHWHSWHMHWHSMHMHWESWHM
At | 5 days Wed 20-01-10 1 Tue 26-01-10
At 2 Sdays Mon11-01-10  Fri15-01-10
Aot 3 Sdays Mon18-01-100  Fri22-01-10
Act 4 Sdays Mon25-01-100  Fri28-01-10

Figure 29 - Effects of Zero Remaining Duration

This ‘hybrid’ behavior is similar to that displayed with the P6 Actual Dates CPM calculation option.

As seen with the examples above, using these options has serious implications of automatically

changing or assigning Actual Dates.

Therefore the scheduler should clearly understand these

options before using them. If the scheduler is not comfortable with these options, the same results

can be achieved by using the “Reschedule Uncompleted Work to Start After” on the Update Project

form except for preventing Actual Dates in the future.

Activities with progress that are in the future can be identified by running a filter and then can be

manually corrected. This is no different than using Primavera products since none of the Primavera

products have a built-in feature to prevent assigning actual dates in the future.
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3.4. Comparing Schedules

It is important to realize that there will be changes to the schedule logic as well as differences
between the planned progress and actual progress. Changes to the schedule logic and planned
durations are revisions to the schedule and they will be calculated to take place in future to the
right of the status date. Other variances due to the performance will be in the past to the left of
the data date. Variances in the performance should be handled separately from the logic revisions
and planned duration changes.

3.4.1. ldentifying Variances

To identify variances in performance, Start Variance and Finish Variance columns can be used. In
addition, schedulers can create custom bar styles to display baseline and schedule update
information in the same view. MSP has a Gantt chart wizard (Figure 30) that allows users to create

these views easily and quickly however schedulers should be aware that using this wizard will

overwrite any existing custom formatting.

Gantt Chart Wizard

Wehat kind of information do wou wank to display in your
Gantt Chart?

{3 Skandard
() Critical path

) Custom Gantt Chart

[ Zancel ][ < Back ” Mext = ][ Finish

Figure 30 — Gantt Chart Wizard
For a more detailed analysis, the actual dates and planned dates can easily be extracted from MSP
and moved to an Excel spreadsheet or to MS Access database to perform a Daily Delay Measure

analysis (MIP 3.2) [6] This can be further automated using Excel or Access formulas and macros.

Remember, that we can only note variances to the early dates and not the late dates. Variance

analysis cannot take activity float into consideration.
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3.4.2. ldentifying Revisions

MSP 2007 has a Compare Project Versions utility to review differences between two similar MSP
schedules. The Compare Project Versions utility compares tasks and resources only and does not
compare resource assignments. This utility produces a comparison report which looks like a
project schedule. Although this report displays color coding and indicators that provide
information about tasks and resources, it is extremely hard to understand, especially for schedulers

who have been using Claim Digger or SureChange.

On the other hand, MSP has a powerful Visual Basic for Applications (VBA) programming language
which allows a quick development for custom comparison software. MSP users can create their
own comparison routines and easily create their own variance reports. Exporting schedules to MS

Access and using it to compare the two similar schedules is another option open to the scheduler.

A quick survey noted third-party software providers who specialize in MSP comparison tools to

include the following,

) Acumen Fuse
J Project Analyzer
4 Conclusion

MSP is inexpensive, very user friendly (especially for beginners) and provides decent default
reports and graphs. A casual user of MS Office with no scheduling experience can pick MSP up and
quickly create schedules. However a seasoned scheduler working on a construction contract is
likely to struggle with updating and maintaining the schedule. Some of the “ease of use” features
function at the expense of the CPM theory, which become sources of confusion for a seasoned

scheduler. The main areas are:

1) MSP Baseline management is cumbersome and confusing for the average scheduler.
2) MSP updating method of using % Complete is not suitable for construction schedules.
3) MSP Data Date issues which in effect complicate the schedule update process are

confusing for construction schedulers.

23



MS Project 2013

Table of Contents
L oL 4T T - | N i
L0 o S i
Pl R OUISITES .iieereeeriiiiiiiereniiiiiiiiteneniisetiieennsssssesttsesnsssssssssssssnnsssssssssssssnssssssssssssnsssssssssssssnnnssssssssssnnnnnssssss i
DiSClaimer & COPYIIZNT ...uuuueeeeiisnssisiissssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssnss i
Table Of CONTENTS.......ueeiiiriiie e a s s sa s e s san e s an e s sa s s anenen i
1. MSPROJECT 2013 = SETTINGS. ..ottt s s e s s e s e sereeenan 1
2. MS PROJECT 2013 — INTRODUCTION .....ceiiiiiiirie et ereree e since s e s e semne e e s e e 8
Project ManagemENt ......cceuuiiiiiiiiiiieiiiiitieeneneiseetreeennssssssssssesnnssssssssssesnnssssssssssssnnnsssssssssssnnnnssssssssssnnnnnssnss 8
3. MS PROJECT 2013 — GETTING STARTED .....cvtiiiiiiiiiiriiiiiiiiinitcniincc e nenee e 10
IMIS PrOJECE Ul ....ceeeiiiiiiiiiieeiicniiitenensieesssseennnssssssssssennnssssssssssesnnssssssssssssnnssssssssssssnnnsssssssssssnnnnssssssssssnnnnns 10
4. MS PROJECT 2013 — CREATE ANEW PLAN .....coiriiiiiiiiriiciiiiccincc e 12
LAUNCH IVIS PrOJECT .....cuuuueeennnnennnnnnnssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssses 12
Create Blank ProjECt ......cccciiiiiiiiiiiiiiiiiiniiiiiiiisssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssnns 12
Project INfOrMAtioN........ucririiirrrrisssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssnns 13
Change File Properties ......ccccciiiiiiiiiiiiiiiiiiiiiiniiiisssissssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssns 18
T 11T I I T QI 19
4= g I T 20
o4 2=T g0 LT LT o Ut 20
Change Default Time DIMENSIONS .....cccieeeeeeniiiiiiiiieiceieeerrerernesseesereeernnsssssseseeennnnssssssssesennsssssssssessnnnnssnnns 21
141 2=] g I T QT 1o Ut 22
[ EToLY=T0 [ 0 TUT 11 T 22
Create MiIleStoNES........ucieiieeiiereertereceneee e e s a e s a e s e s e s e s a e as 24
Create SUMMANY Task ....ccciiiiiiiiiiiiiiiiiiiiiiiiisisssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssns 25
T - 27
RESPECE LINKS .eevvvrrriiiniiiiisiiisississsssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssss 29

-
o

@I tutorialspoint

= AEYLEARMNING



MS Project 2013

Switching Task — Manual t0 AUtOMAtIC ....cccciiiiiiiiiiiiiii s s s e e e e e e 31
Converting Task to Automatic SChedule.........cciiiiiiriccccccrrrrrrcsrrr s snes 31
MS PROJECT 2013 — SET UP RESOURCES........cotttiiiiriiiiirieeeeeeeerinerereeeeesesesrneneeesesesesennnene 34
RESOUICE TYPES cecuuiiiriniiiiiiniiiiiiuiiiiiieiiiirieiiiieneiiiieasstisnssstissssssmssssssmsssssstssssssssnsssstssssssssnsssssanssssssnsssssansssnes 34
Enter WOork ReSOUICE NAMEES .....cciiiiiiiieereiiiiiiiiiinereeiiiisisssnsseessssssssssssssssssssssssssssessssssssssssssesssssssssssnssnnns 34
[IC=T o TUT o= 1V D O T o T T 1 Y 35
[0 2T gl 1= o TUT g of - 0e - N 37
Add NOLES £0 RESOUICES .....coiiiiuuuenrieiiiiiiiiierteeiiiiiiiereeesssssssssse e e ssssssssss s e e s sssssssssseessssssssssssseenssssssssnns 38
Set UP COSt RESOUICES..cuuiiiiueiiiiiniiiiiniiiiteeiiiiesisimeesiiimessiiimssssimssssimssssimassstssssstmssssstsasssstsssssstsnssssssnnsss 39
MS PROJECT 2013 — ASSIGN RESOURCES TO TASK.....uuiiiiiiiieieeirireteee e einereeeee e s 41
Assign Material ReSource t0 TasK......cccceeiiiiiiiiiiiiiiiiieiesesssss s s s s s s s ss s s s s s e e e s s s sesssesssesssssssssssssssnnnsnnnnnns 41
Assign Cost Resource t0 Tasks......ccciiiiiiiiiiiiiiiiiiiiiissssssssssssssssssssssssssssssssssssssssssssssssssssssssssssnes 44
PLAN DURATION, COST, & TIME.....cciiiiiieiitieieee e e e eecccteteeee e e e e eeetneeeee e e s e seeestneseeeeeeesenennnsnens 46
Check Plan’s DUFation .......cciiueeiiiiiiiiiiiiniiiiietiiieeeiieeensenessssstesesssessessnessesssnesesssssesesssnessesssnessssnnee 46
(00T Yol Q8 o T o NS 46
CheCk Plan’s WOTK .....ccoiueeiiiiieiiiiiiniiiiiitiiieniiiseeeiissieesissnesissssesissseesessnessesssnesssssssesesssnessssssnessssanee 47
MS PROJECT 2013 —TRACK PROGRESS ........eeeireiiieieeerirrrirtee s s sinercre e e s s insnenenesenenens 49
SaVE @ BASEIINE c.coiiiiiieeeeieiiiiccerr et s e e e s aae 49
Create @ BaSEliNe ......eeeeeiiiiieeeeiicccctte e aan e 49
View Baseline on Gantt Chart ..........cciviiiieereiiiiiieeeeieeree s ssss s s 50
UPAate @ BaSElINE ....ueeeeeeeeeieieiiissssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssnnns 51
Track Plan by SPeCifiC DAte .......eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeesemeesssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssnnnnnns 53
Track Plan as % COMPIELE ......eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeseeeesssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssnsnnnnnns 54
Track Plan by Actual VAlUES .......ceeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeesmmeeeessssssssssssssssssssssssssssssssssssssssssssssssssssssssssnnnns 55

iii

w ' tutorialspoint

EIMPLYEAEYLEARMNING



MS Project 2013

9. ADVANCED SCHEDULING ... .ttt ettt e e e seirerer e e e e e s s sinerereeesesssesamsneneneaesssesannnnne 57
Adjust Task Link Relationship......ccccoiiiiiiiiiiiiiiiiiiccccc e s e s e s e e e s e s eeeeees 57
oY =T 0 T 61
Enter @ RECUITING TASK .iociiiiiiuereiiiiiiiiiiieireniiisisnrree s sssse e sass s e s s s s ass s e s s s ss s snnsse e s s sesssssnnnnnnns 61
VieW Critical Path........eeeeeeiiiieeentrten et 62
(004 1= o Q=TT o TU T oL Lo Lot T TS 63
Resolve Resource Over AlloCation.........cceeiiiiiiiiieeneiiiiiiiiinnereeniinsseeree s sassse s sssss e s s s ss s annseees 65
Level Overallocated RESOUICES.........cccveeiiiiieeiiiiineiiiieeeissieesiisseessssssessssases s sas e s ssssss e ssssane s sssssnessessnnenes 69
(00 TT ol 1 o T oo S 72

10. PROJECT STATUS REPORTING ...cceeiiiiiiiieieeeeeiriiirert e e e s e sinereee e e s e s sinnneeeeeaesesansnenenesens 75
LI 38T 11T o X1 -{ 1N 75
LI T G e N 76
=270 TV o 0o T 77
[ [T o A3 =T T o 78

iv

w ' tutorialspoint

EIMPLYEAEYLEARMNING



1. MS Project 2013 — Settings

Each one of you might be using a different setting for MS Project 2013. To ensure the
results are not different from what is shown in this tutorials, ensure the settings as follows.
Remember all these are the default settings you will have when you first install MS Project
2013 on your computer.

Step 1: File -> Options -> General tab -> Project view -> Default view.

Select “"Gantt with Timeline” from the dropdown box.
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Step 2: File -> Options -> Display tab -> Show Indicators and Options Buttons For.

Check all options.
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Step 3: File -> Options -> Schedule tab -> Schedule -> Show Assignment Units.

Choose “percentage” from the dropdown box.

- ; : 5
o X O General w— ~ Find =
IB o 1) s Calori s M| Change options related to scheduling calendars, and calculations 1 # Find
3 Copy ~ Display ts & Clear~
Gentt  Paste B I U < Scroll
Chart . Format Painter Sthedilr. D P ] | o Timene 1o Tack 19 Fill-
View Uipboerd Font . ; ok i
" Week starts on: {Sundzy  |v]
S Start Seve Eiscel year starts in: |lanusry v
S Tue22405 N <titting vaar (61 EV toratierin
2 Lergtiage LUse starting year for £Y numbering
Advaboad Default start time: 800 AM These times are assigned to tasks when you enter a start or
TR = finish date without specifying a time, If you change this
«  Task Hame s Bk Default end tme: 500 PM | setting, consider matching the project calendar using the
R i 5 = Change Working Time command on the Project tab in the
Quitk Access Toolber urs per day: fisbon
e Hourz pes week: 40
Dayspermonth: 20 &
Trust Centar = —,
Schedule
[¥] Shaw scheduling messages
& Show assignment units asa: | Percentage| v |
3
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= o o
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Default task type: Fired Units |
[ New tasks are effort driven [ Tasks will shways honot their constraint dates
e
] Autolink inserted or moved tasks V' Show that scheduled tasks have estimated durstions
[} Sghit in-progress tasks W1 Mewr scheduled tasks haye estimated durations v
Prog!
oK Canced

SKS * MANUALLY SCHEDU

6 ® alo

Step 4: File -> Options -> Schedule tab -> Calculation -> Calculate Project after Each
Edit.

Check the On button.
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Step 5: File -> Options -> Save tab -> Save projects -> Save Files In this format.

Select Project (*.mpp).
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Step 6: File -> Options -> Advanced tab -> Edit.
Check all options.
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Step 7: File -> Options -> Advanced tab -> Display -> Show Status Bar -> Show Scroll
Bar.

Both options, Status Bar and Scroll Bar should be checked.
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Step 8: Resources -> Level -> Leveling Options -> Leveling Calculations.

Set to manual.
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Step 9: Resources -> Level -> Leveling Options -> Leveling calculations -> Look for
Overallocations.

Select "Day By Day” from dropdown box.
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2. MS Project 2013 — Introduction

Microsoft Project is a project management software program developed and sold by
Microsoft, designed to assist a project manager in developing a schedule, assigning
resources to tasks, tracking progress, managing the budget, and analyzing workloads.

Project creates budgets based on assignment work and resource rates. As resources are
assigned to tasks and assignment work estimated, the program calculates the cost, equal
to the work times the rate, which rolls up to the task level and then to any summary task,
and finally to the project level.

Each resource can have its own calendar, which defines what days and shifts a resource
is available. Microsoft Project is not suitable for solving problems of available materials
(resources) constrained production. Additional software is necessary to manage a complex
facility that produces physical goods.

Project Management

MS Project is feature rich, but project management techniques are required to drive a
project effectively. A lot of project managers get confused between a schedule and a plan.
MS Project can help you in creating a Schedule for the project even with the provided
constraints. It cannot Plan for you. As a project manager you should be able to answer the
following specific questions as part of the planning process to develop a schedule. MS
Project cannot answer these for you.

¢ What tasks need to be performed to create the deliverables of the project and in
what order? This relates to the scope of the project.

e What are the time constraints and deadlines if any, for different tasks and for the
project as a whole? This relates to the schedule of the project.

e What kind of resources (man/machine/material) are needed to perform each task?

e How much will each task cost to accomplish? This would relate to the cost of the
project.

¢ What kind of risk do we have associated with a particular schedule for the project?
This might affect the scope, cost and time constraints of your project.

Strictly speaking, from the perspective of Project Management Methodology, a Plan and
Schedule are not the same. A plan is a detailed action-oriented, experience and
knowledge-based exercise which considers all elements of strategy, scope, cost, time,
resources, quality and risk for the project.

Scheduling is the science of using mathematical calculations and logic to generate time-
effective sequence of task considering any resource and cost constraints. Schedule is part
of the Plan. In Project Management Methodology, schedule would only mean listing of a
project's milestones, tasks/activities, and deliverables, with start and finish dates. Of
course the schedule is linked with resources, budgets and dependencies.

8
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However, in this tutorial for MS Project (and in all available help for MS Project) the word
‘Plan’ is used as a ‘Schedule’ being created in MS Project. This is because of two reasons.

One, MS Project does more than just create a schedule it can establish dependencies
among tasks, it can create constraints, it can resolve resource conflicts, and it can also
help in reviewing cost and schedule performance over the duration of the project. So it
does help in more than just creating a Schedule. This it makes sense for Microsoft to
market MS Project as a Plan Creator rather than over-simplifying it as just a schedule
creator.

Two, it is due to limitation of generally accepted form of English language, where a
schedule can be both in a noun as well as verb form. As a noun, a Schedule is like a time
table or a series of things to be done or of events to occur at or during a particular time
or period. And in the verb form, schedule is to plan for a certain date. Therefore it is much
easier to say that, "One can schedule a plan from a start date” but very awkward to say,
“One can schedule a schedule from a start date”. The distinction is important for you as a
project manager, but as far as MS project is concerned the noun form of Schedule is a
Plan.

Of course, a project manager should also be able to answer other project-related questions
as well. For example:

e Why this project needs to be run by the organization?

e What's the best way to communicate project details to the stakeholders?
e What is the risk management plan?

e How the vendors are going to be managed?

e How the project is tracked and monitored?

e How the quality is measured and qualified?

MS Project can help you:

e Visualize your project plan in standard defined formats.
e Schedule tasks and resources consistently and effectively.

e Track information about the work, duration, and resource requirements for your
project.

e Generate reports to share in progress meetings.
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3. MS Project 2013 — Getting Started

In this chapter, we will take a close look at the user interface of MS Project.

MS Project Ul

e Windows 7: Click on Start menu, point to All Programs, click Microsoft Office, and
then click Project 2013.

¢ Windows 8: On the Start screen, tap or click Project 2013.

e Windows 10: Click on Start menu -> All apps -> Microsoft Office -> Project 2013.

The following screen is the Project’s start screen. Here you have options to open a new
plan, some other plans, and even a new plan template.

7T - &2 %
2 Search for online templates o Omer Mohammed
ro Ject oyt o
Suggested searches:  Project Management  Project Plan Projects  Schodules  Analysls  Industry  Business Switch accaunt
), =
Re I
—_— .ﬂ _ﬁ
] ——————— my . »
-
-
—_— -
E" ' 1 ’ ‘ I'
- || i
! New from existing project New from Excel workbook New from SharePoins Tasks List
|
SOFTWARE =4 | | [P —
DEVELOPMENT = =T
e Open Other Projects PLAN = = ~
e | <6 = .
Get I | -
Started 5 % = - =
s E | ot v
Welcome to Project Project management institute,. Software Devedopment Plan Aghe project management

= e E alg

Click the Blank Project Tab. The following screen pops up.
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MS Project 2013

The screen should have the MS Project interface displayed. The major part of this interface
are:

¢ Quick Access Toolbar: A customizable area where you can add the frequently
used commands.

e Tabs on the Ribbon, Groups: With the release of Microsoft Office 2007 came the
"Fluent User Interface" or "Fluent UI", which replaced menus and customizable
toolbars with a single "Office menu", a miniature toolbar known as "quick-access
toolbar" and what came to be known as the ribbon having multiple tabs, each
holding a toolbar bearing buttons and occasionally other controls. Toolbar controls
have heterogeneous sizes and are classified in visually distinguishable Groups.
Groups are collections of related commands. Each tab is divided into multiple
groups.

¢ Commands: The specific features you use to perform actions in Project. Each tab
contains several commands. If you point at a command you will see a description
in a tooltip.

e View Label: This appears along the left edge of the active view. Active view is
the one you can see in the main window at a given point in time. Project includes
lots of views like Gantt Chart view, Network Diagram view, Task Usage view, etc.
The View label just tells you about the view you are using currently. Project can
display a single view or multiple views in separate panes.

e View Shortcuts: This lets you switch between frequently used views in Project.
e Zoom Slider: Simply zooms the active view in or out.

e Status bar: Displays details like the scheduling mode of new tasks (manual or
automatic) and details of filter applied to the active view.

11
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4. MS Project 2013 —Create a New Plan

When working with MS Project you either specify a start date or a finish date. Because
once you enter one of the two, and other project tasks, constraints and dependencies, MS
Project will calculate the other date. It is always a good practice to use a start date even
if you know the deadline for the project.

Launch MS Project

e Windows 7: Click on Start menu, point to All Programs, click Microsoft Office, and
then click Project 2013.

¢ Windows 8: On the Start screen, tap or click Project 2013.

e Windows 10: Click on Start menu -> All apps -> Microsoft Office -> Project 2013.

Create Blank Project

MS Project 2013 will display a list of options. In the list of available templates, click Blank
Project.

Guided Tour_Start - Project Professional (Trial) T - 0O X
New
Search for online templates pel

Supgested sewrches:  ProjectMansgement  ProjectPlan Projects  Schedules  Analysic  Industry  Business

|7ﬁ - -
EE- - B Get
‘@ Started |

Blank Projoct Now tiom existing peeject Now from Excel worihonk Now from Sharsboint Tacks Lict Walcome to Project

SOPTEARE ~===1i H 0 Pt 03 Moaye s A et U e " I EARNED VALUE
Optior DEVELOFMENT == - ==
PLAN == - = .
—
Software Development Plan Agile project mansgzment Eamed rolu

Project sets the plan’s start date to current date, a thin green vertical line in the chart
portion of the Gantt Chart View indicates this current date.
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Project Information

Let us change the project start date and add some more information.

Step 1: Start Date

Click Project tab -> Properties Group -> Project Information.

A dialog box appears. In the start date box, type 11/5/15, or click the down arrow to
display the calendar, select November 5, 2015 (or any date of your choice).

Click OK to accept the start date.

Step 2: Set Up Calendar

Click Project tab -> Properties Group -> Project Information.

Click the arrow on the Current Date dropdown box. A list appears containing three base
calendars.

e 24 Hour: A calendar with no non-working time.

¢ Night Shift: Covers 11 PM to 8 AM, night shifts covering all nights from Monday
to Friday, with one hour breaks.

¢ Standard: Regular working hours, Monday to Friday between 8 AM to 5 PM, with
one hour breaks.
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Select a Standard Calendar as your project Calendar. Click “"Cancel” or "OK" to close the
dialog box.

Now let us add exceptions.

Step 3: Adding Exceptions to Calendar

Exceptions are used to modify a Project calendar to have a non-standard workday or a
non-working day. You can also allot unique working hours for a particular resource as well.

Here is an example to create a non-working day, which could be because of a holiday or
office celebrations or events other than the standard office work effort.

Click Project tab -> Properties Group -> Change Working Time.

Change Working Time dialog box appears. Under Exceptions Tab click on the Name
Field, enter event as "Office Anniversary”. In the Start field enter 11/22/15, and then enter
the same date in the Finish field. This date is now scheduled as a non-working day for the
project. You can also verify the changed color indicated in the calendar within the dialog
box as below. Click Ok to close.
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Step 4: Setting up Resource Calendar

Just like you can change a Standard Base Calendar, you can change the work and non-
working time for each resource. You can modify the resource calendar to accommodate
flex-time, vacation time, training time, etc.

Also remember, Resource Calendar can only be applied to work resources and not to
material and cost resources.

By default when we create the resources in a plan, the resource calendar matches the
Standard base calendar. And any changes you make to the Project Calendar, gets
reflected automatically in resource calendars, except when you create an exception in the
resource calendar. In that case even if you update the project calendar, the exception in
resource calendar is not affected.

Click Project tab>Properties group—>Click Change Working Time
Change Working Time dialog box appears.
Click the down arrow for the “For Calendar” drop-down box.

Select the resource for whom you want to create an exception. In example below I

have chosen John.

Under Exceptions Tab click on the Name Field, enter event as “Personal holiday”. In the
Start field enter the date (example 9/15/2015), and then enter the same date in the
Finish field.
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Click Project tab -> Properties group -> Click Change Working Time.

The Change Working Time dialog box appears.

Click the down arrow for the “For Calendar” dropdown box.
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Select the resource for whom you want to change work schedule. In the following
screen you can see we have chosen John.

Click “Work Weeks” tab.
Double-click the [default] cell below the Name column heading.

Under “Selected Day(s)” choose any day you want to change the work schedule. We
have chosen Tuesday and Wednesday.

Click Set day(s) to these specific working times. Change the time.
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Click Project tab -> Properties group -> Click Change Working Time.
The Change Working Time dialog box appears.
Click the down arrow for the “For Calendar” dropdown box.

Select the resource for whom you want to change work schedule. We have chosen

John again.
Click "Work Weeks” tab.
Double-click the [default] cell below the Name column heading.

Under “Selected Day(s)” choose any day you want to change the work schedule.
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Click any day (we have chosen Friday) and use the radio button “Set days to
nonworking time”.

Click OK to close the Dialog box. You will now see all Fridays are greyed out in the
calendar.
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Change File Properties

With Microsoft Windows Operating system, right clicking a file and selecting “Properties”
brings up the file properties dialog box that contains version, security and other file details.

You can record some top level information for your .mpp project file as well. This can be
done as follows:

Step 1: Launch MS Project

¢ Windows 7: Click on Start menu, point to All Programs, click Microsoft Office, and
then click Project 2013.

¢ Windows 8: On the Start screen, tap or click Project 2013.

¢ Windows 10: Click on Start menu -> All apps -> Microsoft Office -> Project 2013.
Step 2: Save Properties

Click File Tab. Under Info Tab go to Project Information. Click arrow near Project
Information to click Advanced Properties. A dialog box opens, you can type in the changes
as required. Click OK and don't forget to save by clicking on Save.
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Build Task List

Before we start, let us assume you already have a Work Breakdown Structure (WBS). In
context of WBS, “Work” refers to “Deliverables” and not effort.

WBS identifies the deliverable at the lowest level as work package. This work package is
decomposed into smaller tasks/activities, which is the effort necessary to complete the
work package. So a task is action-oriented, and the work package is the deliverable or a
result of one or more tasks being performed.

There is a significant amount of confusion between what constitutes an activity and what
constitutes a task within the project management community. But for MS Project, a task
is the effort and action required to produce a particular project deliverable. MS Project
does not use the term “activity”.
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Enter Task

MS Project 2013

This is simple. In Gantt Chart View, just click a cell directly below the Task Name column.
Enter the task name. In the following screen, we have entered 5 different tasks.

Enter Duration

A duration of the task is the estimated amount of time it will take to complete a task. As
a project manager you can estimate a task duration using expert judgment, historical

information, analogous estimates or parametric estimates.

You can enter task duration in terms of different dimensional units of time, namely
minutes, hours, days, weeks, and months. You can use abbreviations for simplicity and

ease as shown in the following table.

Value you want to enter Abbreviation Appearance
45 minutes 45 m 45 mins
2 hours 2h 2 hrs
3 days 3d 3 days
6 weeks 6w 6 weeks
2 months 2mo 2 mons
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Remember, Project default values depend on your work hours. So 1 day is not equivalent
to 24 hours but has 8 hours of work for the day. Of course, you can change these defaults
anytime you want.

Value entered Value Project default Value
1 minute 60 seconds 60 seconds
1 hour 60 minutes 60 minutes
1 day 24 hours 8 hours (1 workday)
1 week 7 days 40 hours (5 workdays)
1 month 28 to 31 days 160 hours (20 workdays)

Change Default Time Dimensions

Click Project tab -> Properties Group -> Click Change Working Time -> Click Options.

You can apply this to all projects or a specific project that you are working on currently.
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One of the neat tricks MS Project possesses is, it considers duration of the task in work-
day sense. So if you have a non-working day in between, it accommodates this and
ensures a task that takes 16 hours to complete to end on the 3™ day. In other words, if
you have a task that needs 16 hours to complete starting on Monday 8:00 AM (if this is
the time your work day starts, and 8 hours being total work hours in a day), and Tuesday
being a holiday, the task will logically end on the evening of Wednesday.

= C M a o sl ?

Tip: With manually scheduled tasks, if you are not sure about a task duration, you can
just enter text such as “Check with Manager/Engineer” to come back to this later.
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Enter Task Duration

This is simple in Gantt Chart View, click the cell below Duration column heading. Enter
the duration. (Task 1 in the following screenshot)

You can also enter Start and Finish date and MS Project will calculate the duration on its
own. (Task 2 in the following screenshot)

You can enter text as well when you don’t have a duration metric currently. (Task 3 and
Task 4 in the following screenshot)
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Note: In the above screenshot, Task 6 is scheduled to start on Sunday, which is a non-
working day and ends on Wednesday. So essentially, one would believe that with these 3
days Monday, Tuesday, Wednesday, the duration calculated would be 3 days. But MS
Project 2013 calculates it as 4 days. So one needs to be careful when choosing the start
date of the task. Because for any successive operation, MS Project 2013 considers that
Task 6 will take 4 days. The next time, you change the start date, the Finish date changes
to reflect this 4-day duration.

Elapsed Duration

Elapsed Duration is the time that elapses while some event is occurring which does not
require any resources. Elapsed duration for a task can be used in instances where a task
will go on round-the-clock without any stoppage. A normal workday has 8 hours, and an
elapsed day duration will have 24 hours. The task also continues over non-working
(holidays and vacations) and working days.
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You can enter elapsed duration by preceding any duration abbreviation with an “e”. So
lew is seven 24-hour days.

For example, when you are ‘Waiting for the paint to dry’. And it takes 4 days for this to
happen. It does not need a resource or a work effort, and all you are doing is waiting for
it to dry. You can use 4ed as the time duration, which signifies 4 elapsed days, the paint
can dry regardless of whether it is a weekend or if it falls on a holiday. Here in this example,
the drying occurs over 24 hours over the weekend.
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Create Milestones

In Project Management, Milestones are specific points in a project timeline. They are used
as major progress points to manage project success and stakeholder expectations. They
are primarily used for review, inputs and budgets.

Mathematically, a milestone is a task of zero duration. And they can be put where there is
a logical conclusion of a phase of work, or at deadlines imposed by the project plan.

There are two ways you can insert a milestone.

Method 1: Inserting a Milestone

Click name of the Task which you want to insert a Milestone

Click Task tab -> Insert group -> Click Milestone.

MS Project names the new task as <New Milestone> with zero-day duration.

Click on <New Milestone> to change its name.

You can see the milestone appear with a rhombus symbol in the Gantt Chart View on the
right.

Method 2: Converting a Task to a Milestone

Click on any particular task or type in a new task under the Task Name Heading.

Under Duration heading type in "0 days ".

MS Project converts it to a Milestone.

Method 3: Converting a Task to a Milestone

In Method 2, a task was converted to a Milestone of Zero duration. But one can also
convert a task of non-zero duration into a Milestone. This is rarely used and causes
confusion.

Double-click a particular Task name.
Task Information dialog box opens.

Click Advanced tab -> select option “"Mark Task as Milestone”.

24

w ' tutorialspoint

= AEYLEARMNING



MS Project 2013

TIMELINE

Maaually Auto

Nestitce

4 4 Task 5 4days

Task 6 4days

GANTT CHART

READY A NEW TRSES : MANUALLY SCHEDULED

0 M t‘ ~ Task Name v Duration ~ Stert F - tv F ' '
Tak 2 5 days Sun 8/20/1S Thu 9/3/15 | 1
2 ol Task4 11 days Thu 9/17/15 Thu10/1/15 3 1
3] ‘ Milostone 1 0 day= £110/2/15 Fn10/2/15 | +02
I

Fri10/2/15 wed10/7/15 3
Thu 10/8/15 Tue 10/13/15 4 t !

BB B 8 - H—
BG  351PM

- me il -
L T

® S B a ols |

Make Project Summary Task visible

The project summary task summarizes your whole project.

In Gantt Chart View -> Format Tab -> Show/Hide -> click to check Project Summary

Task on.

Create Summary Task

There can be a huge number of tasks in a project schedule, it is therefore a good idea to
have a bunch of related tasks rolled up into a Summary Task to help you organize the
plan in a better way. It helps you organize your plan into phases.

In MS Project 2013, you can have several number of sub-tasks under any higher level
task. These higher level tasks are called Summary Task. At an even higher level, they are
called Phases. The highest level of a plan’s outline structure is called the Project
Summary Task, which encompasses the entire project schedule.

Remember because summary task is not a separate task entity but a phase of the project
with several sub-tasks in it, the duration of the summary task is from the start of the first
sub-task to the finish of the last sub-task. This will be automatically calculated by MS
Project.

Of course, you can enter a manual duration of the summary task as well which could be
different from the automatically calculated duration. MS Project will keep track of both but
this can cause significant confusion.

In most cases, you should ensure that there is no manually entered duration for any task
you will be using as a Summary Task.
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Let us use the following screenshot as an example. If you would like to group Task 4 and
Task 5 into a Summary Task 1. You can do it in two ways.
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Method 1
Select the names of Task 4 and Task 5.

Click Task Tab—> group Insert ->Click Summary

MS Project creates a <New Summary Task>.

Rename it to Summary Task 1.

Method 2

You can click Task 4 row.

Select “Insert Task”. A <New Task> is created.

You can rename the Task. Here it is renamed as Summary Task 1. Don’t enter any duration
for this task.

Now select Task 4 and Task 5.

Click Task tab-> Schedule group—>Click Indent Task
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Link Tasks

Once you have a list of tasks ready to accomplish your project objectives, you need to link
them with their task relationships called dependencies. For example, Task 2 can start once
Task 1 has finished. These dependencies are called Links. A Guide to the Project
Management Body of Knowledge (PMBOK Guide) does not define the term
dependency, but refers to it as a logical relationship, which in turn is defined as a
dependency between two activities, or between an activity and a milestone.

In MS Project, the first task is called a predecessor because it precedes tasks that depend
on it. The following task is called the successor because it succeeds, or follows tasks on
which it is dependent. Any task can be a predecessor for one or more successor tasks.
Likewise, any task can be a successor to one or more predecessor tasks.

There are only four types of task dependencies, here we present them with examples.

e Finish to Start (FS): Finish the first floor before starting to build the second floor.
Most used.

e Finish to Finish (FF): Cooking all dishes for dinner to finish on time.

e Start To Start (SS): When doing a survey, we would seek survey responses but
will also start tabulating the responses. One does not have to finish collecting
survey response before starting the tabulation.

e Start to Finish (SF): Exam preparation will end when exam begins. Least used.
In MS Project you can identify the Task Links:

¢ Gantt Chart: In Gantt Chart and Network Diagram views, task relationships
appear as the links connecting tasks.

e Tables: In Tables, task ID numbers of predecessor task appear in the predecessor
fields of successor tasks.

Method 1

Select the two tasks you want to link. In the following screenshot taken as an example,
we have selected names, Task 1 and Task 2.

Click Task tab -> Schedule group -> Link the Selected Tasks.

Task 1 and Task 2 are linked with a Finish-to-Start relationship.

Note: Task 2 will have a Start date of the Next working day from Finish date of Task 1.
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Method 2

Double click a successor task you would like to link.

Here I have clicked Task 4

The Task information dialog box opens

Click Predecessors tab

In the Table, click the empty cell below Task Name column.

A drop down box appears with all Tasks defined in the project.

Choose the predecessor task. Click OK.

Here I have chosen Task 3.
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Method 3

In this method, you will select a group of task, and link them all with Finish-to-Start
relationship.

Select multiple tasks with the help of the mouse -> Task tab -> Schedule group ->
Link the Selected Tasks.

All tasks get linked. To select non-adjacent tasks, hold down Ctrl key and select each task
separately.

Respect Links

If you are in Manually Scheduled mode, any change in duration of the predecessor task
will not reflect on Start date of Task 4. For example, Task 4 starts on 9/3/15 which is the
next day of Finish date of Task 3.
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Now when we change the Duration of Task 3 from 5 to 7 days, the start date is not
automatically updated for Task 4 in Manual Scheduling.
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You can force MS Project to respect the link (dependency) by doing the following:

e Select Task 4.
o Click Task tab -> Schedule group -> Respect Links.
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Switching Task — Manual to Automatic

MS Project by default sets new tasks to be manually scheduled. Scheduling is controlled
in two ways.

Manual Scheduling: This is done to quickly capture some details without actually
scheduling the tasks. You can leave out details for some of the tasks with respect to
duration, start and finish dates, if you don't know them yet.

Automatic Scheduling: This uses the Scheduling engine in MS Project. It calculates
values such as task durations, start dates, and finish dates automatically. It takes into
accounts all constraints, links and calendars.

For example, at Lucerne Publishing, the new book launch plan has been reviewed by the
resources who will carry out the work and by other project stakeholders. Although you
expect the plan to change somewhat as you learn more about the book launch, you now
have enough confidence in the overall plan to switch from manual to automatic task
scheduling.

Converting Task to Automatic Schedule

We have three different methods to convert a task to automatic schedule.

Method 1

If you want to change the mode for a particular task, say Task 5 in the following example.
Click on Task Mode cell in the same row. Then, click the down arrow to open a dropdown
box, you can select Auto Scheduled.
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Method 2
Click Task -> Tasks group -> Auto Schedule.
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Method 3

To switch completely to Auto Schedule mode:

Toggle the scheduling mode of the plan by clicking the New Tasks status bar (at the

bottom-left) and then selecting Auto scheduling mode.

32

' tutorialspoint

EIMPLYEAEYLEARMNING



MS Project 2013

BE - = GANTT CHART TOOLS Project2 - Progect Professionst (Teal) 7T = O XN
TASK RESOURCE REPORT PROJECT vew FORMAT Sgnin § X o
:: d e T - 8 \taik on Track = ” -.) "3 nspect + tan ~1 Summary -~ —.‘-orn -y Mcind -
2 Copy = 9 Respect Links i 73 Move~ ¥ Milestone 1 Details £ Clesi~
Gantt  Paste o BT U DH-A- T F & @ Maasally Asto Task infomation |, Scro __
Chart= - Format Painter = Inactwate Schedule Schadite =7 Mode * - W e 2 A 10 Tameline g5 Taek (¥ Fill *
View Chotserd Forst ic Schedule Tasks Ingert Prapertie Editing -
J oy S
- [Aug 50,15 [eo 1018 [5e0 20,15
o Sttt T e e A Finish
= Wed 472615 S with pates to the T Tue $72
B
Task . g6 1 2039, 1 2 3 " =
o o | Tack Narme » Dunstion v St w»  Fnish v Prodecie - v T LA “ ¥ T v
“ Task 1 2days Wed 8/26/15 Thu 8/27/15 0
# « Summary Task 1 12 days Wed 8/26/1* Thu 9/10/15 E—
3 o Task 3 11 days ‘Wed 8/26/1% Wed 9/9/15 P =
| # o] Taska 1day Thu/10/15 Thu9/10/15 3 [
$ » # Summary Task 2 8 days Frig/11/15 Tue9/22/15 2 [-——]
. Task 6 3days Friof11/15 Tue9/15/15 ==,
= » Task7 3days Wed 9/16/1¢ FriS/18/15 6 famy
z . Task 8 2days Mon 9/21/15 Tue 9/22/15 7 -
E b
&
New Tasio
% Auto Scheduled - Task dates are calcutated by Microsoft Project
<l A Manuaby Scheduled - Task dates are not autamatically updated. e ( ~ v
& NEW TASKS © MANUALLY SCHED!

You

can also change the default scheduling

mode that Project applies to all new plans.

Go to File tab and click Options. Then click Schedule tab and under scheduling options for
this project select “All New Projects” from the dropdown box. Under new tasks created,

select “"Auto Scheduled” from the dropdown box.
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5. MSProject 2013 —Set Up Resources

In project management terminology, resources are required to carry out the project tasks.
They can be people, equipment, facilities, funding, or anything (except labor) required for
the completion of a project task. Optimum Resource Scheduling is the key to successful
project management.

Resource Types

e Work resources: People and equipment to complete the tasks.

e Cost resources: Financial cost associated with a task. Travel expenses, food
expenses, etc.

e Material resources: Consumables used as project proceeds. For example, paint
being used while painting a wall.

Note: Be aware of the crucial difference between People and Equipment resources. People
resources will have limited work hours, say 6, 8 or 12 hours. Equipment resources have
different working capacities of 2, 8 or 24 hours and could have maintenance breaks as
well. Also note, that it is possible multiple people resources might be using one equipment
resource, or one equipment might be accomplishing multiple tasks.

Enter Work Resource Names

You can enter resource names according to your convenience.

Resource Example
Work resource as an identified person John, Kevin
Work resource as a job function or group Engineer, Coordinator, Typist
Work resource as an equipment Lathe machine, Earth mover

Steps involved:

Click View tab -> Resource Views group -> Click Resource Sheet.
Click the cell directly below the Resource Name heading column.

Enter Resources as an individual person, job function or group.

By default, the Max Units field is set to 100%.
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Resource Max Capacity

Max Units field represents the maximum capacity of a resource to work on assigned tasks.
100% stands for 100 percent of resource’s working time is available for work on task
assigned. The resource is available full-time on each workday. If the resource gets
allocated to task or tasks that would require more than his/its work hours, the resource is
over allocated and MS Project will indicate this in red formatting.

If a resource does not represent an individual person but a job function, where a group of
people with the same skill set can work on the task, we can enter larger Max Units to
represent the number of people in the group. So 400% would indicate, 4 individual people
working full-time every workday.

Work Resources as a Group

Click View tab>Resource Views group—->Click Resource Sheet
Click the cell directly below Resource Name heading column
Enter Resources as group, here we take an example of Engineers.

Click the Max. Units field for the Engineers resource.

Type or select 400%. Press Enter.
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Work Resource as Parttime

Entering a value less than 100% in Max.Units would mean you expect the resource
capacity to be lower than a full-time resource. So 50% would mean the individual works
for half of the normal full capacity, so if a normal work week is 40 hours, this equals 20
hour capacity.

Click View tab -> Resource Views group -> Click Resource Sheet.
Click the cell directly below Resource Name heading column.

Enter Resource as an individual or job function. Here let’s take an example.
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Enter Resource Cost

You can enter standard rates and costs per use for work and material resources. You can
also enter overtime rates for work resources. Standard rates are calculated on per hour
basis. Costs per use on the other hand are costs that do not vary with task. Cost per use
is a set fee used up to complete a task. There are three types of resources: work, material,
and cost.

e Work resources: People and equipment to complete the tasks.

e Cost resources: Financial cost associated with a task. Travel expenses, food
expenses, etc.

e Material resources: Consumables used as project proceeds. Like paint being used
while painting a wall.

Note: Be aware of the crucial difference between People and Equipment resources. People
resources will have limited work hours say 6, 8 or 12 hours. Equipment resources can have
different working capacities of 2, 8 or 24 hours and could have maintenance breaks as
well. Also note that it is possible multiple people resources might be using one equipment
resource, or one equipment might be accomplishing multiple tasks.

Cost resources do not use pay rates. Remember cost per use and cost resources are two
different things. Cost resources are financial cost associated with a task, like travel
expenses, food expenses, etc. The cost value of cost resource is only assigned when you
assign cost resource to a task.

Project calculates the cost of a task by using this formula:

Cost of Task = Work Value (in number of hours) x Resource’s Pay Rate.
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You can then see the cost per resource and cost per task (as well as costs rolled up to
summary tasks and the entire plan). MS Project will not automatically apply overtime

calculations.

To enter standard and overtime pay rates for work resources:

Click View tab -> Resource Views group -> Resource Sheet.
Click the cell directly below Resource Name heading column to create Resources.

Click the Std. Rate field for each resource to costs in hourly (default), daily, weekly,
monthly and yearly rates.

In the following example, the resource Rasmus is left at zero. This is useful when you
don’t have to track rate-based costs for some resources.

Click the Ovt. Rate field to enter overtime rates.
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Add Notes to Resources

Click View tab -> Resource Views group -> Resource Sheet.
Double-click the Resource, a Resource Information dialog box opens.

Click on Notes tab. Here let’s enter a note for Rasmus as “Rasmus will work part-
time”.
Click OK.

38

EIMPLYEAEYLEARMNING

) ' tutorialspoint



MS Project 2013

A note icon now appears to the left of Rasmus’ hame in the Resource Sheet view.
Hovering over it will make the note appear.

EH %5 : RESOURCE SHEETTOONS  Project3 - Project P Tral T - D
TASK RESOURCE REPORT PROJECT VIEW FORMAT wgnm 5 b3 0
-: ¥, Cat Catha ir o] e o W Makon Track - . t .~ - ® M Find -
il e @ Copy - Ok & = Linik 5 - o oy A Details # Clest~
T ¥ Format Pairtar = |nact chile Shirdale =9 Made~ : ciiverabic 3 A T e o ¥ Fin-
e lipboard Font 3 schecule Tasks nsert Yoperies

Matecis Max. 514, Acoue | Base
O ResourceMame + Type + el v Witk v Gne Untse Rite - OviRate o CosfUse At = |Colondse v Code  + AddNew Cokima +

John work s 100% 540.00/hr $60.00/hr $0.00 Prorated Standard

Kevin Work 3 50% 000,00/ wk $0.00/hr $0.00 Prorated Standard

3 Sharon Viork s 100% 500.00/wk 50.00/ hr $0.00 Prorated Standard
R — R S0%  $0.00/hr $0.00/hr  $0.00 Provated Standard I

iyiien '3 100%  550.00/hr $0.00/hr $0.00 Prorated Standard

Engineers Viork 3 400%  $40.00/he $0.00/hr $0.00 Prorated Standard

SHEET

RESOURCE

READY o NEW TASKS : MANUALLY SCHEDULED S - B £

e ®ma o slie

Set Up Cost Resources

You can use a cost resource to represent a financial cost associated with a task in a plan.
Examples of cost resources are travel, food, entertainment and training. So it is obvious
that cost resources do no work on a task and do not affect scheduling of a task.

Cost value of the cost resource is entered when assigning it to a task.
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Click View tab -> Resource Views group -> Resource Sheet.
Click the empty cell in the Resource Name column.
Type Training and press the Tab Key.

In the Type field, click the down arrow to select Cost.
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6. MS Project 2013 — Assign Resources to Task

Once the task and resource list are complete, resources need to be assigned to tasks in
order to work on them. With MS Project you can track task progress, resource and tasks
costs.

Assign Material Resource to Task

Method 1

Click View Tab -> Gantt Chart View -> Resource Name column.

Click the box below the Resource Name column for the task you need the resource to

be assigned.

From the dropdown, choose the resource name. In the following screenshot as an

example. For Task 1 "PT1”, we have chosen the resource “Celic”.

You can also select multiple resources to work on a single task.
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Method 2

Click Resource tab -> Under Assignments group -> Assign Resources.
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In the Assign Resources dialog box, click the resource name you like to assign.

Here let’s choose “Hitesh”. Now click the Assign button.

You can also select multiple resources to work on a single task.
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Method 3

Click View Tab -> Gantt Chart -> Task Name column.
Double-click the Task Name. Task Information dialog box opens.
Click the Resources tab.

Click the cell below the Resource Name column. Select the resource from the

dropdown list.

You can also select multiple resources to work on a single task.
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Method 4

Click View Tab -> Split View group -> Details -> Task Form.

The window is split in two, Gantt Chart view and Task Form view below it.

In the Task Form view, click under the Resource Name column and select the

resource.

You can also select multiple resources to work on a single task.
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Assign Cost Resource to Tasks

Click View Tab -> Gantt Chart View -> Task Name column.
Double-click the Task Name. Task Information dialog box opens.
Click the Resources tab.

Click the cell below the Resource Name column. Select the resource from the

dropdown list.

In the following example below, let’s choose “Travel” as cost resource and enter the cost
at $800.

We can also assign other material resources to the same task.
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7. Plan Duration, Cost, & Time

After assigning resources to tasks you can view the cost, duration and work required for
the plan to complete.

Check Plan’s Duration

In Gantt Chart View -> View Tab -> Split View group -> Timeline checkbox.

You will be able to see the plan’s start and finish dates.

In the Gantt Chart view, you can also look at the project summary task, to note the
duration, start and finish dates of the plan.

In the following example, Assign Resources is the project summary task (identified as Task
0). Duration=53 days, Start date: 1/5/15 and Finish Date: 3/19/15.

One can switch Project Summary Task on by following these steps:

In Gantt Chart View -> Format Tab -> Show/Hide -> To check Project Summary Task on.
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Check Plan’s Cost

Click View tab -> Data group -> Tables -> Cost.

46

Stutorialspoint

SIMPLYEAESEYLEARNING




MS Project 2013

Cost for each task gets rolled up into summary tasks, and then ultimately to project
summary task.
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Check Plan’s Work

Click Report Tab > View Reports group - click Resources - click Resource overview
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In Resource status table which appears at the bottom, you will get a summary of resource’s
earliest start dates and latest finish dates as well as remaining work.
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Check Project Statistics

Click Project Tab -> Properties group -> Project Information -> in the new dialog box

click Statistics...
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8. MS Project 2013 —Track Progress

Once your project plan is ready in MS Project, it becomes essential for a project manager
to measure the actuals (in terms of work completed, resources used and costs incurred)
and to revise and change information about tasks and resources due to any changes to
the plans. A Project Manager should not assume that everything is progressing according
to plan and should always keep track of each task. Resistance to formal tracking of project
management data is normal. You can overcome resistance to tracking by explaining your
expectations, explaining the benefits of tracking, and training people to track the task
themselves.

Save a Baseline

To evaluate project performance you need to create a baseline against which you will
compare the progress. One needs to save the baseline, once a plan is fully developed. Of
course, due to rolling wave planning or progressive elaboration needed to manage projects
one can always add new tasks, resources, constraints and costs to the plan.

Also note, it makes sense to save the baseline before entering any actual values such as
percentage of task completion.

Note: With MS Project 2013, you can save up to 11 Baselines in a Single plan. These
multiple baselines seem contrary to the definition of baseline. You can use this flexibility
when:

e You have a baseline plan for the external customer and another for the internal
team.

e You are preparing for a risk event. You want to develop separate baseline plans for
risk response and recovery.

e You are accommodating a big change request, you might still want to keep the
original plan for future reference when communicating with a stakeholder.

Create a Baseline

Click Project Tab -> Schedule group -> Set Baseline -> OK.
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Update a Baseline

As time and work progresses on a project, you might need to change the baseline as well.
You have several options for the same:

e Update the baseline.
e Update the baseline for selected tasks.

e Save multiple baselines.

Update the Baseline for the Entire Project

This simply replaces the original baseline values with the currently scheduled values.

Click Project Tab -> Schedule group -> Set Baseline -> OK.

Update the Baseline for Selected Tasks

This does not affect the baseline values for other tasks or resource baseline values in the
plan.

Click Project Tab -> Schedule group -> Set Baseline -> For select Selected tasks -> OK.

Save Multiple Baselines

You can save up to 11 baselines in a single plan. The first one is called Baseline, and the
rest are Baseline 1 through Baseline 10.

Click Project Tab -> Schedule group -> Set Baseline -> click the dropdown box to
save any baseline you like.

Click OK.
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Interim Plans

An interim plan saves only two kinds of information for each task - Current start dates and
Current finish dates.

It can be used as a project marker. It is visually easy to see how off-track or on-track the
project progress is. Because it only specifies dates, it is simple, clear and easy information.

Click Project Tab -> Schedule group -> Set Baseline -> Set interim plan -> OK.
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Track Plan by Specific Date

If all tasks have started and are finished as scheduled, you can record this in the Update
Project dialog box. Most of the times, a seasoned project manager understands that this
isn't true. But sometimes this approach might be fine when the actual work and cost values
generated are close enough to your baseline schedule.

Click Project tab -> Status group -> Update Project.

Switch on the radio button for "Update work as complete through” option, and then
Set 0% -100% complete. Select the current date.

Click OK.
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Check marks will appear in the indicators column for tasks that have been completed. On
the right in the Chart portion, progress bars are generated in the Gantt bars of each task.
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Method 2

Click View tab -> Data group -> Tables -> Tracking.

Now for the required Task, click the corresponding % Comp column and enter the required
% complete.

Track Plan by Actual Values

You can enter the following actual values for your project:

e Actual Start and finish dates - Project moves the schedule accordingly.

e Task’s Actual duration - If equal or greater than schedule duration: task = 100%
complete.

Task’s Actual Duration

Click View Tab -> Data group -> Tables -> Work.

You will see the % W. Comp. (% work complete) column.
This table includes Work (Scheduled work), Actual, and Remaining columns.

Click on Task you want to update. In the following example, Task 9’s Actual field is clicked
and 24 hours is entered. For this task, initial scheduled Work was 16 hours, because 24
hours is greater. The project marks the task as 100% complete and updates the Work
column to 24 hours (from initial 16 hours). In the example, a Baseline is saved, because
the Baseline does not change and is used as a comparison. The Baseline is still at 16 hours
and a Variance of 8 hours is now calculated by MS Project.

Note: Actual work is rolled up and also reflects on the summary task.
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Actual Start and Finish Dates

Click Task whose dates you would like to change.

Change Start or Finish field in Actual group.

Click Task tab -> Schedule group -> dropdown menu for Mark on Track -> Update Tasks.

You can fill Actual duration field as well.
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9. Advanced Scheduling

There are four types of task dependencies.

e Finish to Start (FS): Finish the first floor before starting to build the second floor.
Most used.

¢ Finish to Finish (FF): Cooking all the dishes for dinner to finish on time.
e Start to Start (SS): When doing a survey, we would seek survey responses but
will also start tabulating the responses. One does not have to finish collecting

survey responses before starting the tabulation.

e Start to Finish (SF): Exam preparation will end when exam begins. Least used.

Adjust Task Link Relationship

Click Task Tab -> double-click the required task under Task Name column -> Task
Information dialog box opens -> Predecessors Tab.

Click the box under the Type column and choose the relationship according to your
requirement.
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Apply Lead and Lag

By default when you link tasks they are assigned a “Finish to Start” relationship. In this
relationship,

e Lead: Lead time causes successor task to begin before its predecessor tasks ends.

e Lag: Lag time causes successor task to start after its predecessor task ends.

Click Task Tab -> double-click the required Task under Task Name column -> Task
Information dialog box opens -> Predecessors Tab.

Under Lag heading column, enter the lag in terms of hours, days, weeks, or years. You
can also apply lag or lead as a percentage. If you enter 50% for the selected Task which
is 6 days long, the task is delayed by 3 days after the predecessor ends.

Lag is entered as positive units and lead in negative units (example,-3d or -50%).
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Apply Task Constraints

Each task created in MS Project 2013 will be constrained as “As Soon As Possible” by
default when Automatic Scheduling is turned ON. As Soon As Possible means the task
starts as soon as the project starts, if there are no dependencies that would delay it. So,
no fixed start or end dates are imposed by this constraint type, but of course predecessor
and successor dependencies are maintained.

When MS Project 2013 performs calculations to save you time in a project that’s running
late, constraint settings are enforced.
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There are 8 Task Constraints.

MS Project 2013

Constraint Constraint Description
type name
Task is scheduled as late as possible with the task
As Late As ending before the project ends and without delaying
Possible (ALAP) | subsequent tasks. Default constraint when you
schedule from the project finish date. Do not enter a
Flexible task start or finish date with this constraint.
As Soon As Task is scheduled to begin as early as possible.
Possible (ASAP) | Default constraint when you schedule from the
project start date. Do not enter a start or finish date
with this constraint.
Start No Earlier | Task is scheduled to start on or after a specified date.
Than (SNET)
Semi-
Flexible Finish No Earlier | Task is scheduled to finish on or after a specified
Than (FNET) date.
Start No Later | Task is scheduled to start on or before a specified
Than (SNLT) date.
Finish No Later | Task is scheduled to finish on or before a specified
Than (FNLT) date.
Must Finish On | Task is scheduled to finish on a specified date.
Inflexible (MFO)
Must Start On Task is scheduled to start on a specified date.
(MSO)
Click Task Tab -> double-click the required Task under Task Name column -> Task
Information dialog box opens -> Advanced Tab.
Click dropdown box for Constraint type. Choose the constraint you would like to
apply.
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Enter Deadline Date

If you use Tasks Constraints, you limit your scheduling flexibility, where MS Project 2013
will fix a particular start or finish date of the task according to the constraint. It is a better
idea to use a Deadline Date which has no effect on the scheduling of a task or summary
task. MS Project will alert you with a red exclamation symbol in the indicators column, if
the scheduled completion of the task exceeds its deadline date.

Click Task Tab -> double-click the required Task under Task Name column -> Task
Information dialog box opens -> Advanced Tab.
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Enter Fixed Cost

Fixed Cost is associated with a task that is not tied to any resources or amount of work.
Click View Tab -> Data group -> Tables -> Cost.

Enter the cost under the Fixed Cost column for the task of interest. In the following
example, we have assigned a fixed cost of $500 to Task 7.
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Enter a Recurring Task

Status meetings, status reports, inspection dates can recur with a particular frequency. In
MS Project 2013, you can specify recurring tasks without having to assign tasks each time
separately. You can also assign resources to these task.

In Gantt Chart View -> Task Tab -> Insert group -> dropdown box for Task -> Recurring
Task.

Enter Task Name and choose Recurrence pattern.

You can also choose a specific time for the task to start as well. By default Project
schedules a recurring task to start on plan’s default start time. You can add time value in
the Start box for Recurring Task Information dialog box to change this. In the following
figure, start time of 10:00 AM is entered.
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View Critical Path

Critical Path is the succession of connected tasks that will take the longest to complete.
The word “critical” does not mean that the tasks are complex or important or need to be
closely monitored, but the focus is on terms schedule that will affect the project finish
date.

So, if you want to shorten the duration of a project, you should first start with
activities/tasks on the critical path. Critical path can be a single sequence of tasks (a single
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critical path) or there can be more than 1 critical paths for a single project. While schedule
changes are made, it is also likely that the critical path will change from time to time.

One needs to always focus on the Critical Path first, when one wants to apply fast-tracking
or crashing to shorten the project duration.

Slack or Float are key to understanding Critical path. There are two types of Float:

¢ Free Float: It is the amount of time a task can be delayed without delaying another
task.

e Total Float: It is the amount of time a task can be delayed without delaying the
completion of the project.

In Gantt Chart view -> Format Tab -> Bar Styles Group -> Check the Critical Tasks
box ON.

All task bars in the critical path, in the Gantt Chart View on the right, will turn Red in color.
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Check Resource Allocations

Relationship between a resource’s capacity and task assignments is called allocation.

This can defined by 3 states:

e Under allocated: An Engineer who works for 40 hours a week, has work assigned
for only 20 hours.

e Fully allocated: A skilled worker who works for 40 hours a week, is assigned 40
hours of work in that week.
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e Over allocated: A carpenter is assigned 65 hours of work, when he only has a 40
hour workweek.

In Gantt Chart View

Click View Tab -> Task Views group -> Gantt Chart view.

Gantt Chart View displays some limited resource information, as shown in the following
screenshot.

It summarizes whether there may be a problem by the red over allocated icon in the
indicator column.
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L

Click View Tab -> Resource Views group -> Resource Usage view.

The Resource Usage view displays resources and all tasks assigned to them underneath
the Resource Name. The left-hand side of the screen lists the Resources and the Task
Names together with columns of total information for the resource or assignment. The
right-hand side shows a time-phased view.
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You can also collapse the outline in the table to see total work per resource over time.

Click on Resource Name column heading.

Click View Tab -> Data group -> Outline -> Hide Subtasks.
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Resolve Resource Over Allocation

One would need to either change the scope (reduce the amount of work), assign more
resources, or accept a longer schedule to resolve overallocation.
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This can be achieved by using some of the following techniques:

Adjust Schedule

By changing its lead or lag time when the resource has more tasks assigned than can be
completed during a given time period. If you add delay that is less than or equal to the
amount of slack on the task, you will not affect the finish date of the project.

By default when you link tasks, they are assigned a “Finish to Start” relationship. In this
relationship,

e Lead: Lead time causes successor task to begin before its predecessor tasks ends.

e Lag: Lag time causes successor task to start after its predecessor task ends.

Click Task Tab -> double-click the required Task under Task Name column -> Task
Information dialog box opens -> Predecessors Tab.

Under Lag heading column, enter the lag in terms of hours, days, weeks, or years. You
can also apply lag or lead as a percentage. If you enter 50% for the selected Task which
is 6 days long, the task is delayed by 3 days after the predecessor ends.

Lag is entered as positive units and lead in negative units (example,-3d or -50%).
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Substitute Resources or Add Additional Resources

You can manually allot some other resource to the task.

Click View Tab -> Gantt Chart View -> Resource Name column.

Click the box below the Resource Name column for the task you need the resource to
be assigned.
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From the dropdown, choose the resource name. In the following example, for Task 1
“PT1”, we have chosen the resource “Celic”.

You can also select multiple resources to work on a single task.
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Reduce Assigned Work

Click View Tab -> Resource Views group -> Resource Usage view.

In the following example, Trish Patrick is over allocated, the Resource Name and Work
appear in red.
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On View tab -> Zoom group -> Timescale box -> Days.

You can also right-click on the Time-phased grid in the right hand side window to display
amount of overallocation by switching on overallocation.
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Now you can reduce the assigned hours. In the following example, 8-hour assignment is
reduced to 4-hour assignments. Not only is Trish Patrick’s work reduced but total work in
the plan has changed. You will also notice a new icon in the indicator column to let you
know that the assignment work has been edited.
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Decrease Task Duration

You can decrease task duration (if no actual work has been entered) to reduce the amount
of work required of the resource, who is assigned to complete the task. If actual work has
been recorded, you must manually reduce the remaining work on the task.

Remove Overallocated Resource

You can just remove a resource assignment from an overallocated resource.

Level Overallocated Resources

If resources are overallocated you can use resource-leveling feature in MS Project 2013.
It works by either splitting tasks or by adding delay to tasks to ensure the resource is not
overloaded. Leveling can delay the individual task finish dates and even the project finish
date. Project does not change who is assigned to each task, total work, or assignment unit
values.

Project first delays tasks to use up any available slack. Once the slack becomes zero, MS
Project 2013 makes changes according to priorities, dependency relationships and task
constraints (such as a Finish No Later Than constraint).

Set Priorities

It is always better to set task priorities (this is a measure of a task's importance/availability
for leveling). You can enter value between 1 and 1000, according to the amount of control
you like in the leveling process. A priority level of 1000 will ensure MS Project does not
level a particular task. By default, priority is set at 500 or a medium level of control. Tasks
that have lower priority are delayed or split before those that have higher priority.

Click View Tab -> Task Views -> Gantt chart View.
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In the Gantt chart table area, scroll to the right to see Add New Column.
Click on the dropdown box and select Priority.
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Now you can add priority to each task as required.
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f = Task 8 1day? Wed 6/24/15 'Wed 6/24/15 Zaki Winster Zaki Winster
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Leveling

Steps in the Leveling process are only a few, but it is important to understand what each
option does. The steps are as follows:
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Click on View Tab -> Resource View group -> Resource Sheet.

Click Resource tab -> Level group -> Leveling Options -> Level All.

Project does leveling and overallocated indicators are removed (If leveling is done
completely, sometimes this might not happen).

In the following section, we will look at Leveling Options in detail:

Click Resource tab -> Level group -> Leveling Options.
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In Resource Leveling dialog box, under Level calculations, try to use Manual more often.
This will ensure MS Project 2013 does the leveling process only when you ask it to, and
not as soon as a resource becomes overallocated even if you don’t want it to (when you
choose Automatic option). For examples, if a resource is overallocated, for say half an
hour more in a week, from 40 hours to 40.5 hours, you wouldn’t want this to inconvenience
you by getting automatically leveled.

In Resource Leveling dialog box, under Level calculations, choose Day by Day basis for
“Look for overallocations on a” option. Doing so will not level resources, but it will
determine when Project displays overallocation indicators next to resource names.

In Resource Leveling dialog box, under Level calculations, use the clear leveling values
before leveling checkbox is selected. Doing so will ensure Project removes any existing
leveling delays from all tasks and assignments before leveling. And if you previously
leveled the plan and then added more assignments, you might want checkbox to be
unchecked to ensure you don’t lose the previous leveling results.

In Resource Leveling dialog box, under Leveling range for “....... ”, you can choose Level
entire project. Here you choose to level either the entire plan or only assignments that fall
within a date range you specify.
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In Resource Leveling dialog box, under Resolving overallocations, Leveling order dropdown
box you can choose Standard. You have 3 options here:

ID only option delays tasks only according to their ID numbers. Numerically higher
ID numbers (for example, 10) will be delayed before numerically lower ID numbers.
You might want to use this option when your plan has no task relationships or
constraints.

Standard option delays tasks according to predecessor relationships, start dates,
task constraints, slack, priority, and IDs.

Priority, standard option looks at the task priority value before the other
standard criteria (Task priority is a numeric ranking between 0 and 1000).

In Resource Leveling dialog box, under Resolving overallocations, you have several options
that you can select. These are explained as follows:

Level only within available slack. Selecting this checkbox would prevent Project
from extending the plan’s finish date. MS Project will use only the free slack within
the existing schedule, which could mean that resource overallocations might not
be fully resolved.

Leveling can adjust individual assignments. Selecting this checkbox allows
Project to add a leveling delay (or split work on assignments if Leveling Can Create
Splits in Remaining Work is also selected) independently of any other resources
assigned to the same task. This might cause resources to start and finish work on
a task at different times.

Leveling can create splits in remaining work checkbox. This allows Project to
split work on a task (or on an assignment if Leveling Can Adjust Individual
Assignments on a Task is also selected) as a way of resolving overallocation.

Level manually scheduled tasks. Selecting this allows Project to level a manually
scheduled task just as it would an automatically scheduled task.

Check Plan’s Cost

Types of cost in a project life cycle includes:

Baseline costs: All planned costs as saved in baseline plan.

Actual costs: Costs that have been incurred for tasks, resources or assignments.
Remaining costs: Difference between baseline/current costs and actual costs.
Current costs: When plans are changed due to assigning or removing resources,
or adding or subtracting tasks, MS Project 2013 will recalculate all costs. This will

appear under the fields labeled Cost or Total Cost. If you have started to track
actual cost, it will include actual cost + remaining cost per task.

Method 1
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You can view plan’s cost values in the Project Statistics dialog box.

Click Project tab -> Properties Group -> Project Information -> Statistics...
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Method 2

Click View tab -> Task Views group -> Other Views -> Task Sheet.

Click View tab -> Data group -> Tables -> Cost.
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10. Project Status Reporting

After creating a project plan and baselines, the project begins. At this stage, the project
manager would be focusing on collecting, monitoring, analyzing project performance, and
updating project status by communicating with the stakeholders.

When there is a difference between what is planned and the actual project performance,
it is called a Variance. Variance is mostly measured in terms of Time and Cost.

Task Slippage

There are several ways to view task with variance.

Method 1: Graphical View by Tracking Gantt

Click View tab -> Task Views group -> Gantt Chart dropdown -> Tracking Gantt.

By comparing the currently scheduled Gantt bars with baseline Gantt bars, you can see
what tasks started later than planned or took longer to complete.
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Method 2: Graphical View by Detail Gantt

Click View tab -> Task Views group -> Other Views -> double-click Tracking Gantt.
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Method 3: Variance Table

Click View tab -> Data group -> Tables -> Variance.

Method 4: Filters

Click View tab -> Data group -> Filters -> More Filters -> choose filter as Late tasks,
Slipping task, etc.

MS Project 2013 will filter the task list to show only the tasks filtered in this process. So if
you select Slipping Task, you will view only incomplete tasks. Any task that is already
completed will not show up.

Task Costs

To examine cost in a project life cycle, you should be aware of these terms and what they
mean in MS Project 2013:

e Baseline costs: All planned costs as saved in baseline plan.
e Actual costs: Costs that have been incurred for tasks, resources, or assignments.

¢ Remaining costs: Difference between baseline/current costs and actual costs.
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e Current costs: When plans are changed due to assigning or removing resources,
or adding or subtracting tasks, MS Project 2013 will recalculate all costs. This will
appear under the fields labeled Cost or Total Cost. If you have started to track
actual cost, it will include actual cost+ remaining cost (uncompleted task) per task.

e Variance: Difference between Baseline Cost and the Total Cost (current or
scheduled cost).

Click View Tab -> Data group -> Tables -> Cost.
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You will be able to view all relevant information. You can also use filters to see tasks that
have run over budget.

Click View tab -> Data group -> Filters -> More Filters -> Cost Overbudget -> Apply.

Resource Cost

For some organizations, resources costs are primary costs, and sometimes the only cost,
so these need to be closely watched.

Click View tab -> Resource Views group -> Resource Sheet.

Click View tab -> Data group -> Tables -> Cost.

We can sort the Cost column to see which resources are the most and least costly.

Click the AutoFilter arrow in Cost column heading, when the drop-down menu appears,
click on Sort Largest to Smallest.
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You can use the AutoFilter feature for each of the columns, By sorting Variance column,
you will be able to see the variance pattern.
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Project Report

Project 2013 comes with a set of predefined reports and dashboards. You’ll find all of these
on the Report tab. You can create and customize graphical reports for your project as well.

Dashboard Reports

Click Report -> View Reports group -> Dashboards.

Resource Reports

Click Report -> View Reports group -> Resources.

Cost Reports

Click Report -> View Reports group -> Costs.

Progress Reports

Click Report -> View Reports group -> In Progress.

Custom Reports
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Click Report -> View Reports group -> New Report.

There are four options.

e Blank: Creates a blank canvas. Use the Report Tools - Design tab to add charts,
tables, text, and images.

e Chart: Creates a chart comparing Actual Work, Remaining Work, and Work by
default. Use the Field List pane to pick different fields to compare. The look of the
chart can be changed by clicking on Chart Tools tabs, Design, and Layout tabs.

e Table: Creates a table. Use the Field List pane to choose what fields to display in
the table (Name, Start, Finish, and % Complete appear by default). Outline level
box lets you select how many levels in the project outline the table should show.
The look of the table can be changed by clicking on Table Tools tabs, Design, and
Layout tabs.

e Comparison: Creates two charts side-by-side. Charts will have the same data at

first. You can click one of the charts and pick the data you want in the Field List
pane to begin differentiating them.
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